aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-05-03 16:37:24 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:08 +0800
commit51747b31c65d6ba5e2d6b1ca28f6b1ab8542a080 (patch)
treeb7f50fa1b590c5328a36d4f556a8bc7d884bc4e7 /gnu/packages/kde-plasma.scm
parentfc1eae71f5ad02e5e5b1db5c8fc597ceee5b39d1 (diff)
downloadguix-51747b31c65d6ba5e2d6b1ca28f6b1ab8542a080.tar.gz
guix-51747b31c65d6ba5e2d6b1ca28f6b1ab8542a080.zip
gnu: Add kglobalacceld.
* gnu/packages/kde-plasma.scm (kglobalacceld): New variable. Change-Id: I1db889a1b0e59634adf776527ea9bacec5d526ae
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index e0c68e7b37..cd27917c2c 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -579,6 +579,51 @@ KDE Frameworks 5 to better interact with the system.")
(home-page "https://invent.kde.org/plasma/kgamma5")
(license license:gpl2+)))
+(define-public kglobalacceld
+ (package
+ (name "kglobalacceld")
+ (version "6.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/"
+ version "/" name "-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1p38lqiw9r1w6grp5847pm9lh27d765in62fnc2vlrkb99krxcr7"))))
+ (build-system qt-build-system)
+ (arguments (list #:qtbase qtbase
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'setenv
+ (lambda _
+ (setenv "HOME" (getcwd))))
+ (replace 'check
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+ (invoke "dbus-launch" "ctest" "-j"
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1")))))))
+ (native-inputs (list extra-cmake-modules dbus))
+ (inputs (list kconfig
+ kcoreaddons
+ kcrash
+ kdbusaddons
+ kwindowsystem
+ kglobalaccel
+ kservice
+ kio
+ kjobwidgets
+ xcb-util-keysyms
+ libxkbcommon))
+ (synopsis "Daemon providing Global Keyboard Shortcut (Accelerator)
+functionality")
+ (description
+ "This package provides a Daemon providing Global Keyboard Shortcut
+(Accelerator) functionality.")
+ (home-page "https://invent.kde.org/plasma/kglobalacceld")
+ (license license:gpl2+)))
+
(define-public khotkeys
(package
(name "khotkeys")