aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-29 07:26:37 +0200
committerMarius Bakke <marius@gnu.org>2022-09-29 07:26:37 +0200
commitf66067febc111d03929c95c067f0b88a8f8abb7b (patch)
treed571997c6756f60a9e9ddd6396e46d05ca7e0dde /gnu/packages/kde-frameworks.scm
parent5dc5d6fa8136f067c85295d88018a7cd8b7cfe40 (diff)
parent45eac6cdf5c8d9d7b0c564b105c790d2d2007799 (diff)
downloadguix-f66067febc111d03929c95c067f0b88a8f8abb7b.tar.gz
guix-f66067febc111d03929c95c067f0b88a8f8abb7b.zip
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm27
1 files changed, 17 insertions, 10 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index bec8ff1c51..87c9884284 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -92,7 +92,7 @@
(define-public extra-cmake-modules
(package
(name "extra-cmake-modules")
- (version "5.96.0")
+ (version "5.98.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -101,7 +101,7 @@
name "-" version ".tar.xz"))
(sha256
(base32
- "1ngxjvf584zgfb93s5sbr5f5nyw0sqc5i0jlbcgbrjg2n83l9ddx"))))
+ "0669m98vqy4hpacfjs7xpgjj1bns24kjybrjipxzp82092g8y69w"))))
(build-system cmake-build-system)
(native-inputs
;; Add test dependency, except on armhf where building it is too
@@ -569,7 +569,7 @@ propagate their changes to their respective configuration files.")
(define-public kcoreaddons
(package
(name "kcoreaddons")
- (version "5.96.0")
+ (version "5.98.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -578,7 +578,7 @@ propagate their changes to their respective configuration files.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1n5mzj02si8allg907l6vn77c2i95qdgfvn48gsqgalwlyd4q6nj"))))
+ "0lqmyxqsw7w1qgdgmax63v64cy7dwk7n4zi8k53xmrqjmd9jir52"))))
(build-system cmake-build-system)
(native-inputs
(list extra-cmake-modules qttools-5 shared-mime-info))
@@ -588,13 +588,20 @@ propagate their changes to their respective configuration files.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
+ (add-before 'check 'blacklist-failing-test
+ (lambda _
+ ;; Blacklist failing tests.
+ (with-output-to-file "autotests/BLACKLIST"
+ (lambda _
+ ;; FIXME: Make it pass. Test failure caused by stout/stderr
+ ;; being interleaved.
+ (display "[test_channels]\n*\n")
+ ;; FIXME
+ (display "[test_inheritance]\n*\n")))))
+ (add-before 'check 'check-setup
+ (lambda _
(setenv "HOME" (getcwd))
- (setenv "TMPDIR" (getcwd))
- (when tests? ;; kdirwatch test fails inconsistently. kprocesstest fails.
- (invoke "ctest" "-E" "(kdirwatch_qfswatch_unittest|kprocesstest|\
-kdirwatch_stat_unittest)")))))))
+ (setenv "TMPDIR" (getcwd)))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Qt addon library with a collection of non-GUI utilities")
(description "KCoreAddons provides classes built on top of QtCore to