aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-09-27 23:30:05 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:05 +0100
commit27eb4944bb140cf4832c44c8fd11397622b3d69e (patch)
tree74f7fdc40337a735203901a0b44cb9c688d6c247 /gnu/packages/kde-frameworks.scm
parent5f3c3d53eb711684ea3dad651689d506e61fb8e2 (diff)
downloadguix-27eb4944bb140cf4832c44c8fd11397622b3d69e.tar.gz
guix-27eb4944bb140cf4832c44c8fd11397622b3d69e.zip
gnu: ktexteditor: Add more inputs.
* gnu/packages/kde-frameworks.scm (ktexteditor)[arguments]: Use gexp. Enable passing test. [inputs]: Add editorconfig-core-c and kparts Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index b4760bfa30..4d05689e82 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -84,6 +84,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages text-editors)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
#:use-module (gnu packages vulkan)
@@ -3054,7 +3055,7 @@ types or handled by application specific code.")
(native-inputs
(list extra-cmake-modules pkg-config))
(inputs
- (list ;; TODO: editor-config
+ (list editorconfig-core-c
karchive
kauth
kbookmarks
@@ -3069,6 +3070,7 @@ types or handled by application specific code.")
kitemviews
ki18n
kjobwidgets
+ kparts
kservice
ktextwidgets
kwidgetsaddons
@@ -3082,23 +3084,23 @@ types or handled by application specific code.")
solid
sonnet))
(arguments
- `(#:phases
- (modify-phases %standard-phases
+ (list #:phases
+ #~(modify-phases %standard-phases
(add-after 'unpack 'setup
(lambda* (#:key inputs #:allow-other-keys)
(setenv "XDG_DATA_DIRS" ; FIXME build phase doesn't find parts.desktop
- (string-append (assoc-ref inputs "kparts") "/share"))))
+ (string-append #$(this-package-input "kparts") "/share"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests? ;; Maybe locale issues with tests?
(setenv "QT_QPA_PLATFORM" "offscreen")
- (invoke "ctest" "-E" "(completion_test|kateview_test|movingrange_test)"))))
+ (invoke "ctest" "-E" "(kateview_test|movingrange_test)"))))
(add-after 'install 'add-symlinks
;; Some package(s) (e.g. plasma-sdk) refer to these service types
;; by the wrong name. I would prefer to patch those packages, but
;; I cannot find the files!
(lambda* (#:key outputs #:allow-other-keys)
- (let ((kst5 (string-append (assoc-ref outputs "out")
+ (let ((kst5 (string-append #$output
"/share/kservicetypes5/")))
(symlink (string-append kst5 "ktexteditorplugin.desktop")
(string-append kst5 "ktexteditor-plugin.desktop"))))))))