aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-02 14:33:57 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-30 15:10:41 +0000
commit09da0d3f0b8212afb76cb2c34226deadec9c44e4 (patch)
treefef454b4ccfde59450c0c5c40e2923e6007f719b /gnu/packages/julia-xyz.scm
parent813accee3fd88c8cf9ff67432964fcfc9957f4a0 (diff)
downloadguix-09da0d3f0b8212afb76cb2c34226deadec9c44e4.tar.gz
guix-09da0d3f0b8212afb76cb2c34226deadec9c44e4.zip
gnu: Add julia-astroangles.
* gnu/packages/julia-xyz.scm (julia-astroangles): New variable. Change-Id: I7d4f977577b5e468eee313e216ed5f3d15f7e598
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 77385ee6e0..5cba99c02e 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -266,6 +266,30 @@ appropriate BLAS or optimised Julia linear algebra routines. This supports a
much wider class of matrix types than Julia's in-built @code{StridedArray}.")
(license license:expat)))
+(define-public julia-astroangles
+ (package
+ (name "julia-astroangles")
+ (version "0.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaAstro/AstroAngles.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hd03kv1dppdzz7i9jv11f4rby5c21sdyhbcf3yvba9vnkkd1gz5"))))
+ (build-system julia-build-system)
+ (native-inputs
+ (list julia-formatting
+ julia-stablerngs))
+ (home-page "https://github.com/JuliaAstro/AstroAngles.jl")
+ (synopsis "Lightweight string parsing and representation of angles")
+ (description
+ "This package provides a lightweight string parsing and representation of
+angles.")
+ (license license:expat)))
+
(define-public julia-astrolib
(package
(name "julia-astrolib")