aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/java-compression.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-08-26 18:35:14 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-08-26 18:35:14 +0200
commit17dddeeee560527a8f30d37761949d658056cb09 (patch)
tree15b0b19c55787f556eb9b42c28d173bddc5435db /gnu/packages/java-compression.scm
parent331a09654eb7e9f6212b7e8469077fa7393e8b11 (diff)
parent6a9581741e4ee81226aeb2f1c997df76670a6aab (diff)
downloadguix-17dddeeee560527a8f30d37761949d658056cb09.tar.gz
guix-17dddeeee560527a8f30d37761949d658056cb09.zip
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/java-compression.scm')
-rw-r--r--gnu/packages/java-compression.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/java-compression.scm b/gnu/packages/java-compression.scm
index 112f04af53..654d138c33 100644
--- a/gnu/packages/java-compression.scm
+++ b/gnu/packages/java-compression.scm
@@ -36,7 +36,7 @@
(define-public java-snappy
(package
(name "java-snappy")
- (version "1.1.7.3")
+ (version "1.1.7.5")
(source
(origin
(method git-fetch)
@@ -44,7 +44,7 @@
(url "https://github.com/xerial/snappy-java")
(commit version)))
(sha256
- (base32 "07c145w1kv8g7dbwpy5xss142il7zr0qq78p2ih76azgl97n5cba"))
+ (base32 "0894zyasrmbi268d1ky9db16wrnc6x8b9ilq0b5paaxi2pwgjlrp"))
(file-name (git-file-name name version))))
(build-system ant-build-system)
(arguments
td> 2021-04-13tests: halt: Fix it....This fixes: <https://issues.guix.gnu.org/47727>. The OCR prompt detection is failing, so remove it altogether. It looks like the test doesn't need the prompt detection delay to work properly. * gnu/tests/base.scm (run-halt-test): Remove failing OCR detection. Mathieu Othacehe 2020-10-26tests: Fix nss-mdns test....* gnu/tests/base.scm (run-nss-mdns-test): Use full "avahi-browse" path. Mathieu Othacehe 2020-09-10tests: install: Fix gui-installed-desktop-os-encrypted test....* gnu/tests/base.scm (run-basic-test): Add a 'desktop?' argument. Wait 30 seconds before trying to switch to TTY1 on desktop. * gnu/tests/install.scm (guided-installation-test): Use 512MiB of RAM and pass the desktop argument to "run-basic-test". Mathieu Othacehe 2020-04-07services: guix: Add 'set-http-proxy' action....Fixes <https://bugs.gnu.org/25569>. Reported by Divan Santana <divan@santanas.co.za>. * gnu/services/base.scm (shepherd-set-http-proxy-action): New procedure. (guix-shepherd-service): Add 'actions' field. Change 'start' to a lambda; check the value of the "http_proxy" environment variable and add "http_proxy" and "https_proxy" to #:environment-variables as a function of that. * gnu/tests/base.scm (run-basic-test)["guix-daemon set-http-proxy action", "guix-daemon set-http-proxy action, clear"]: New tests. * doc/guix.texi (Base Services): Document it. Ludovic Courtès 2020-04-06services: syslog: Create log files as non-world-readable....Partly fixes <https://bugs.gnu.org/40405>. Reported by Diego Nicola Barbato <dnbarbato@posteo.de>. * gnu/services/base.scm (syslog-service-type): Change 'start' method to set umask to #o137 before spawning syslogd. * gnu/tests/base.scm (run-basic-test)["/var/log/messages is not world-readable"]: New test. Ludovic Courtès 2020-03-05tests: 'run-basic-test' can enter a root password....* gnu/tests/base.scm (run-basic-test): Add #:root-password and honor it. Ludovic Courtès