aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/installers.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-08 15:47:00 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-08 15:47:00 -0400
commit533a893cc6b03f100566760d6e0c8e0500ed7082 (patch)
tree0ecbf89895a400c43d16bb1f6539f1a88aeaa4cf /gnu/packages/installers.scm
parent6a2546f92d07df04e5d700924edd027ed1e2ef11 (diff)
parentc762df54786fd6f005f3b5307323f1d2df3cbf0b (diff)
downloadguix-533a893cc6b03f100566760d6e0c8e0500ed7082.tar.gz
guix-533a893cc6b03f100566760d6e0c8e0500ed7082.zip
Merge branch 'master' into staging
Conflicts: .guix-authorizations gnu/ci.scm gnu/packages/base.scm gnu/packages/databases.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/imagemagick.scm gnu/packages/password-utils.scm gnu/packages/python-xyz.scm gnu/packages/web-browsers.scm
Diffstat (limited to 'gnu/packages/installers.scm')
-rw-r--r--gnu/packages/installers.scm29
1 files changed, 19 insertions, 10 deletions
diff --git a/gnu/packages/installers.scm b/gnu/packages/installers.scm
index a8a5c36a18..775b91f0f7 100644
--- a/gnu/packages/installers.scm
+++ b/gnu/packages/installers.scm
@@ -92,13 +92,23 @@
;; for native toolchain
(setenv env-name
(filter-delimited-string env-val (negate mingw-path?)))
- ;; Add the removed paths back into
- ;; CROSS_-prefixed version of env vars
+ ;; Add the removed paths back into CROSS_-prefixed
+ ;; version of env vars
(setenv (string-append "CROSS_" env-name)
(filter-delimited-string env-val mingw-path?))))
- '("CPATH" "LIBRARY_PATH"))
+ '("C_INCLUDE_PATH" "CPLUS_INCLUDE_PATH" "LIBRARY_PATH"))
;; Hack to place mingw-w64 path at the end of search
;; paths. Could probably use a specfile and dirafter
+ (setenv "CROSS_C_INCLUDE_PATH"
+ (string-join
+ `(,@(map (cut string-append
+ (assoc-ref %build-inputs "xgcc")
+ "/lib/gcc/" ,triplet "/"
+ ,(package-version xgcc) <>)
+ '("/include"
+ "/include-fixed"))
+ ,(getenv "CROSS_C_INCLUDE_PATH"))
+ ":"))
(setenv "CROSS_CPLUS_INCLUDE_PATH"
(string-join
`(,@(map (cut string-append (assoc-ref %build-inputs "xgcc") <>)
@@ -108,21 +118,20 @@
,@(map (cut string-append "/lib/gcc/" ,triplet "/" ,(package-version xgcc) <>)
'("/include"
"/include-fixed"))))
- ,(getenv "CROSS_CPATH"))
+ ,(getenv "CROSS_CPLUS_INCLUDE_PATH"))
":"))))
(add-before 'build 'fix-target-detection
(lambda _
- ;; NSIS target detection is screwed up, manually
- ;; change it ourselves
+ ;; NSIS target detection is screwed up, manually change
+ ;; it ourselves
(substitute* "Source/build.cpp" (("m_target_type=TARGET_X86ANSI")
(string-append "m_target_type=" ,nsis-target-type))))))))
(home-page "http://nsis.sourceforge.net/")
(synopsis "A professional open source system to create Windows installers")
(description
- "NSIS (Nullsoft Scriptable Install System) is a professional open
-source system to create Windows installers. It is designed to be as small and
-flexible as possible and is therefore very suitable for internet
-distribution.")
+ "NSIS (Nullsoft Scriptable Install System) is a professional open source
+system to create Windows installers. It is designed to be as small and flexible
+as possible and is therefore very suitable for internet distribution.")
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution.")))))