aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/inkscape.scm
diff options
context:
space:
mode:
authorRene Saavedra <pacoon@protonmail.com>2020-04-27 23:59:18 -0500
committerLudovic Courtès <ludo@gnu.org>2020-05-01 01:21:03 +0200
commit7ff2159b10774fc9a3cb99adcd778aa4693ca9ee (patch)
tree087620556d00ba983f008a55bd29028c511e841e /gnu/packages/inkscape.scm
parent69de98391d720b92206d5e45072ecd3944d95774 (diff)
downloadguix-7ff2159b10774fc9a3cb99adcd778aa4693ca9ee.tar.gz
guix-7ff2159b10774fc9a3cb99adcd778aa4693ca9ee.zip
gnu: balsa: Update to 2.6.0.
* gnu/packages/mail.scm (balsa): Update to 2.6.0. [inputs]: Replace gmime-2.6 with gmime; add libical and libsecret. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/inkscape.scm')
0 files changed, 0 insertions, 0 deletions
;id=9199ab584667357122637df49eb96919b0a04eb8'>lib/parse.js93
-rw-r--r--lib/utils.js6
3 files changed, 38 insertions, 76 deletions
diff --git a/lib/output.js b/lib/output.js
index b9d8a137..d59176c3 100644
--- a/lib/output.js
+++ b/lib/output.js
@@ -91,13 +91,11 @@ function OutputStream(options) {
comment_filter = function(comment) {
return comment.type != "comment5" && comments.test(comment.value);
};
- }
- else if (typeof comments === "function") {
+ } else if (typeof comments === "function") {
comment_filter = function(comment) {
return comment.type != "comment5" && comments(this, comment);
};
- }
- else if (comments === "some") {
+ } else if (comments === "some") {
comment_filter = is_some_comments;
} else { // NOTE includes "all" option
comment_filter = return_true;
@@ -643,8 +641,7 @@ function OutputStream(options) {
var self = this, generator = self._codegen;
if (self instanceof AST_Scope) {
active_scope = self;
- }
- else if (!use_asm && self instanceof AST_Directive && self.value == "use asm") {
+ } else if (!use_asm && self instanceof AST_Directive && self.value == "use asm") {
use_asm = active_scope;
}
function doit() {
@@ -1043,11 +1040,9 @@ function OutputStream(options) {
return;
}
b = b.alternative;
- }
- else if (b instanceof AST_StatementWithBody) {
+ } else if (b instanceof AST_StatementWithBody) {
b = b.body;
- }
- else break;
+ } else break;
}
force_statement(self.body, output);
}
diff --git a/lib/parse.js b/lib/parse.js
index b7639df4..7321878f 100644
--- a/lib/parse.js
+++ b/lib/parse.js
@@ -234,6 +234,7 @@ function tokenizer($TEXT, filename, html5_comments, shebang) {
directives : {},
directive_stack : []
};
+ var prev_was_dot = false;
function peek() {
return S.text.charAt(S.pos);
@@ -286,16 +287,12 @@ function tokenizer($TEXT, filename, html5_comments, shebang) {
S.tokpos = S.pos;
}
- var prev_was_dot = false;
function token(type, value, is_comment) {
- S.regex_allowed = ((type == "operator" && !UNARY_POSTFIX[value]) ||
- (type == "keyword" && KEYWORDS_BEFORE_EXPRESSION[value]) ||
- (type == "punc" && PUNC_BEFORE_EXPRESSION[value]));
- if (type == "punc" && value == ".") {
- prev_was_dot = true;
- } else if (!is_comment) {
- prev_was_dot = false;
- }
+ S.regex_allowed = type == "operator" && !UNARY_POSTFIX[value]
+ || type == "keyword" && KEYWORDS_BEFORE_EXPRESSION[value]
+ || type == "punc" && PUNC_BEFORE_EXPRESSION[value];
+ if (type == "punc" && value == ".") prev_was_dot = true;
+ else if (!is_comment) prev_was_dot = false;
var ret = {
type : type,
value : value,
@@ -358,11 +355,8 @@ function tokenizer($TEXT, filename, html5_comments, shebang) {
parse_error("Legacy octal literals are not allowed in strict mode");
}
var valid = parse_js_number(num);
- if (!isNaN(valid)) {
- return token("num", valid);
- } else {
- parse_error("Invalid syntax: " + num);
- }
+ if (!isNaN(valid)) return token("num", valid);
+ parse_error("Invalid syntax: " + num);
}
function read_escaped_char(in_string) {
@@ -463,8 +457,7 @@ function tokenizer($TEXT, filename, html5_comments, shebang) {
if (ch == "\\") escaped = backslash = true, next();
else if (is_identifier_char(ch)) name += next();
else break;
- }
- else {
+ } else {
if (ch != "u") parse_error("Expecting UnicodeEscapeSequence -- uXXXX");
ch = read_escaped_char();
if (!is_identifier_char(ch)) parse_error("Unicode char: " + ch.charCodeAt(0) + " is not valid in identifier");
@@ -538,9 +531,7 @@ function tokenizer($TEXT, filename, html5_comments, shebang) {
function handle_dot() {
next();
- return is_digit(peek().charCodeAt(0))
- ? read_num(".")
- : token("punc", ".");
+ return is_digit(peek().charCodeAt(0)) ? read_num(".") : token("punc", ".");
}
function read_word() {
@@ -592,11 +583,10 @@ function tokenizer($TEXT, filename, html5_comments, shebang) {
switch (code) {
case 34: case 39: return read_string(ch);
case 46: return handle_dot();
- case 47: {
- var tok = handle_slash();
- if (tok === next_token) continue;
- return tok;
- }
+ case 47:
+ var tok = handle_slash();
+ if (tok === next_token) continue;
+ return tok;
}
if (is_digit(code)) return read_num();
if (PUNC_CHARS[ch]) return token("punc", next());
@@ -614,12 +604,8 @@ function tokenizer($TEXT, filename, html5_comments, shebang) {
next_token.add_directive = function(directive) {
S.directive_stack[S.directive_stack.length - 1].push(directive);
-
- if (S.directives[directive] === undefined) {
- S.directives[directive] = 1;
- } else {
- S.directives[directive]++;
- }
+ if (S.directives[directive]) S.directives[directive]++;
+ else S.directives[directive] = 1;
}
next_token.push_directives_stack = function() {
@@ -627,13 +613,10 @@ function tokenizer($TEXT, filename, html5_comments, shebang) {
}
next_token.pop_directives_stack = function() {
- var directives = S.directive_stack[S.directive_stack.length - 1];
-
- for (var i = 0; i < directives.length; i++) {
+ var directives = S.directive_stack.pop();
+ for (var i = directives.length; --i >= 0;) {
S.directives[directives[i]]--;
}
-
- S.directive_stack.pop();
}
next_token.has_directive = function(directive) {
@@ -645,27 +628,17 @@ function tokenizer($TEXT, filename, html5_comments, shebang) {
/* -----[ Parser (constants) ]----- */
-var UNARY_PREFIX = makePredicate([
- "typeof",
- "void",
- "delete",
- "--",
- "++",
- "!",
- "~",
- "-",
- "+"
-]);
+var UNARY_PREFIX = makePredicate("typeof void delete -- ++ ! ~ - +");
-var UNARY_POSTFIX = makePredicate([ "--", "++" ]);
+var UNARY_POSTFIX = makePredicate("-- ++");
-var ASSIGNMENT = makePredicate([ "=", "+=", "-=", "/=", "*=", "%=", ">>=", "<<=", ">>>=", "|=", "^=", "&=" ]);
+var ASSIGNMENT = makePredicate("= += -= /= *= %= >>= <<= >>>= |= ^= &=");
var PRECEDENCE = function(a, ret) {
- for (var i = 0; i < a.length; ++i) {
- var b = a[i];
- for (var j = 0; j < b.length; ++j) {
- ret[b[j]] = i + 1;
+ for (var i = 0; i < a.length;) {
+ var b = a[i++];
+ for (var j = 0; j < b.length; j++) {
+ ret[b[j]] = i;
}
}
return ret;
@@ -682,7 +655,7 @@ var PRECEDENCE = function(a, ret) {
["*", "/", "%"]
], {});
-var ATOMIC_START_TOKEN = makePredicate([ "atom", "num", "string", "regexp", "name" ]);
+var ATOMIC_START_TOKEN = makePredicate("atom num string regexp name");
/* -----[ Parser ]----- */
@@ -698,10 +671,9 @@ function parse($TEXT, options) {
}, true);
var S = {
- input : (typeof $TEXT == "string"
- ? tokenizer($TEXT, options.filename,
- options.html5_comments, options.shebang)
- : $TEXT),
+ input : typeof $TEXT == "string"
+ ? tokenizer($TEXT, options.filename, options.html5_comments, options.shebang)
+ : $TEXT,
token : null,
prev : null,
peeked : null,
@@ -757,15 +729,12 @@ function parse($TEXT, options) {
}
function unexpected(token) {
- if (token == null)
- token = S.token;
+ if (token == null) token = S.token;
token_error(token, "Unexpected token: " + token_to_string(token.type, token.value));
}
function expect_token(type, val) {
- if (is(type, val)) {
- return next();
- }
+ if (is(type, val)) return next();
token_error(S.token, "Unexpected token: " + token_to_string(S.token.type, S.token.value) + ", expected: " + token_to_string(type, val));
}
diff --git a/lib/utils.js b/lib/utils.js
index 6dcb631e..6ac68bbd 100644
--- a/lib/utils.js
+++ b/lib/utils.js
@@ -127,8 +127,7 @@ var MAP = (function() {
} else {
top.push(val);
}
- }
- else if (val !== skip) {
+ } else if (val !== skip) {
if (val instanceof Splice) {
ret.push.apply(ret, backwards ? val.v.slice().reverse() : val.v);
} else {
@@ -145,8 +144,7 @@ var MAP = (function() {
} else {
for (i = 0; i < a.length; ++i) if (doit()) break;
}
- }
- else {
+ } else {
for (i in a) if (HOP(a, i)) if (doit()) break;
}
return top.concat(ret);