aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-11-09 11:36:43 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-03 08:39:00 +0100
commitde8196f571d1d7b113e503fa2eb162f49002dd59 (patch)
treede50e892d9cf50ff0980357378af667600baa0c7 /gnu/packages/hurd.scm
parentba8fb8c2fb4b3643894b867f5088d3a558ac30b5 (diff)
downloadguix-de8196f571d1d7b113e503fa2eb162f49002dd59.tar.gz
guix-de8196f571d1d7b113e503fa2eb162f49002dd59.zip
gnu: rumpkernel: Support the 64bit Hurd.
* gnu/packages/hurd.scm (rumpkernel)[argument]: In stage "build", follow Debian upstream to use -DPAE disable the DTRACE and ZFS builds. Change-Id: I534da31eefb378c72b4896d64a51a73109e38aa6
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 0df514cc78..6701d00251 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -792,6 +792,9 @@ in userland processes thanks to the DDE layer.")
"-V" "MKBINUTILS=no"
"-V" "MKGDB=no"
"-V" "MKGROFF=no"
+ "-V" "MKDTRACE=no"
+ "-V" "MKZFS=no"
+
"-V" (string-append "TOPRUMP=" toprump)
"-V" "BUILDRUMP_CPPFLAGS=-Wno-error=stringop-overread"
"-V" "RUMPUSER_EXTERNAL_DPLIBS=pthread"
@@ -802,7 +805,8 @@ in userland processes thanks to the DDE layer.")
" -DRUMP_REGISTER_T=int"
" -DRUMPUSER_CONFIG=yes"
" -DNO_PCI_MSI_MSIX=yes"
- " -DNUSB_DMA=1")
+ " -DNUSB_DMA=1"
+ " -DPAE")
"-V" (string-append
"CWARNFLAGS="
" -Wno-error=maybe-uninitialized"