aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-13 17:21:32 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-13 17:21:32 +0200
commit15406013fe63f2ab238eec2d7a8adbc586806ac8 (patch)
tree8377d7c70a925f7c5ea4c04473c4eb547610b64b /gnu/packages/hurd.scm
parenta3ac317ab4a90f66ac65055fa26dee58ed2367b8 (diff)
parentdd4c1992103a65b8fbdc80fe07a9fe9be822769a (diff)
downloadguix-15406013fe63f2ab238eec2d7a8adbc586806ac8.tar.gz
guix-15406013fe63f2ab238eec2d7a8adbc586806ac8.zip
Merge branch 'master' into emacs-team
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm15
1 files changed, 1 insertions, 14 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 34c7c00f2d..c9f77d799a 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -46,20 +46,7 @@
#:use-module (gnu packages texinfo)
#:use-module (gnu packages onc-rpc)
#:use-module (gnu packages xorg) ; libpciaccess
- #:use-module (guix git-download)
- #:export (hurd-system?
- hurd-target?))
-
-(define (hurd-target?)
- "Return true if the cross-compilation target or the current system is
-GNU/Hurd."
- (or (and=> (%current-target-system) target-hurd?)
- (and (not (%current-target-system))
- (and=> (%current-system) target-hurd?))))
-
-(define (hurd-system?)
- "Return true if the current system is the Hurd."
- (and=> (%current-system) target-hurd?))
+ #:use-module (guix git-download))
(define (hurd-source-url version)
(string-append "mirror://gnu/hurd/hurd-"