aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-04-07 14:03:00 +0200
committerFederico Beffa <beffa@fbengineering.ch>2015-04-08 17:31:12 +0200
commitdc0ae39a8f53d7672962e3640a18b51bb14eb8a5 (patch)
tree24dcb23f8562e885fbdce1c2bf1b9b78f25cf9c2 /gnu/packages/haskell.scm
parentc272160ab0632a71a7de4c79442419622ecb9dfe (diff)
downloadguix-dc0ae39a8f53d7672962e3640a18b51bb14eb8a5.tar.gz
guix-dc0ae39a8f53d7672962e3640a18b51bb14eb8a5.zip
gnu: Add ghc-quickcheck.
* gnu/packages/haskell.scm (ghc-quickcheck): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 088a154cb0..31bc5ff3b0 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -507,4 +507,34 @@ the paper \"Splittable Pseudorandom Number Generators Using Cryptographic
Hashing\" by Claessen, Pałka for details and the rationale of the design.")
(license bsd-3)))
+(define-public ghc-quickcheck
+ (package
+ (name "ghc-quickcheck")
+ (version "2.8")
+ (outputs '("out" "doc"))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/QuickCheck/QuickCheck-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "04xs6mq22bcnkpi616qrbm7jlivh9csnhmvjgp1ifq52an1wr4rx"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:tests? #f ; FIXME: currently missing libraries used for tests.
+ #:configure-flags '("-f base4")))
+ ;; these inputs are necessary to use this package
+ (propagated-inputs
+ `(("ghc-tf-random" ,ghc-tf-random)))
+ (home-page
+ "https://github.com/nick8325/quickcheck")
+ (synopsis
+ "Automatic testing of Haskell programs")
+ (description
+ "QuickCheck is a library for random testing of program properties.")
+ (license bsd-3)))
+
;;; haskell.scm ends here