aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-03-27 14:49:39 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-04-08 17:31:12 +0200
commita39f3936a9eea02e4beb38680da42cf0fe37828f (patch)
tree7ab6f4aed2dfaa527092a3910e2d48dfd37d299d /gnu/packages/haskell.scm
parent3d3613d55d534f386adf09322d394b771eb3b2ec (diff)
downloadguix-a39f3936a9eea02e4beb38680da42cf0fe37828f.tar.gz
guix-a39f3936a9eea02e4beb38680da42cf0fe37828f.zip
gnu: Add ghc-stm.
* gnu/packages/haskell.scm (ghc-stm): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index ac55d9245c..0c86d508c6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -306,4 +306,26 @@ most tasks and for the few cases where more control is needed it provides
access to the full zlib feature set.")
(license bsd-3)))
+(define-public ghc-stm
+ (package
+ (name "ghc-stm")
+ (version "2.4.4")
+ (outputs '("out" "doc"))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/stm/stm-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0gc8zvdijp3rwmidkpxv76b4i0dc8dw6nbd92rxl4vxl0655iysx"))))
+ (build-system haskell-build-system)
+ (home-page "http://hackage.haskell.org/package/stm")
+ (synopsis "Software Transactional Memory")
+ (description
+ "A modular composable concurrency abstraction.")
+ (license bsd-3)))
+
;;; haskell.scm ends here