aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-02-24 06:29:31 +0000
committerLudovic Courtès <ludo@gnu.org>2017-03-11 12:43:36 +0100
commita15638034ef3d7bcfabe365b2f222479c8608ddd (patch)
tree2ae21ddaa85c10744f18c8297bacae2a4fa1651d /gnu/packages/haskell.scm
parent55fa53491b18bac6683eefb16ab70e6dc13869ef (diff)
downloadguix-a15638034ef3d7bcfabe365b2f222479c8608ddd.tar.gz
guix-a15638034ef3d7bcfabe365b2f222479c8608ddd.zip
gnu: Add ghc-unexceptionalio.
* gnu/packages/haskell.scm (ghc-unexceptionalio): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d0f659f6e3..2415881e8e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8194,4 +8194,22 @@ or filter messages based on the priority and source. It also has a syslog
handler built in.")
(license license:bsd-3)))
+(define-public ghc-unexceptionalio
+ (package
+ (name "ghc-unexceptionalio")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "unexceptionalio-" version "/" "unexceptionalio-"
+ version ".tar.gz"))
+ (sha256 (base32 "1f7h7zwky4scdcyjspg4ksfh7x6yra0wjybxq70p7vcwpgk2nzlj"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/singpolyma/unexceptionalio")
+ (synopsis "IO without any non-error, synchronous exceptions")
+ (description "When you've caught all the exceptions that can be
+handled safely, this is what you're left with.")
+ (license license:isc)))
+
;;; haskell.scm ends here
/span>Ludovic Courtès 2016-04-03build: Add a Guile custom test driver using SRFI-64....Mathieu Lirzin 2016-03-06tests: Disable grafting by default for most tests....Ludovic Courtès 2015-12-20profiles: Honor search paths of propagated inputs....Ludovic Courtès 2015-05-18profiles: Gracefully deal with packages containing an etc/ symlink....Ludovic Courtès 2015-05-08profiles: Ensure the profile's etc/ directory is writable....Ludovic Courtès 2015-05-06tests: Fix etc/profile test....Taylan Ulrich Bayırlı/Kammer 2015-05-06profiles: Generate an 'etc/profile' file....Ludovic Courtès 2015-05-02profiles: Store search paths in manifests....Ludovic Courtès 2015-04-15profiles: Generalize "hooks" for 'profile-derivation'....Ludovic Courtès 2015-04-08profiles: Generate GHC's package database cache....Federico Beffa 2015-03-17gexp: Add <gexp-input>....Ludovic Courtès 2015-03-04tests: Remove dependency on 'glibc-utf8-locales' for profile tests....Ludovic Courtès 2015-02-09profiles: Report "pseudo-upgrades" as upgrades, not downgrades....Ludovic Courtès 2015-02-08profiles: Distinguish downgrades from upgrades....Ludovic Courtès 2014-12-15tests: Use 'test-assertm' for profiles....Ludovic Courtès 2014-10-10ui: Move 'show-manifest-transaction' from (guix profiles)....Alex Kost 2014-09-04profiles: Use a real arrow to denote upgrades in ASCII....Ludovic Courtès 2014-09-02profiles: Report the old and new version number in upgrades....Ludovic Courtès 2014-08-30profiles: Compute transaction effects in a functional way....Ludovic Courtès 2014-08-23Factorize test suite support in (guix tests)....Ludovic Courtès 2014-08-23profiles: Produce a top-level Info 'dir' file....Ludovic Courtès 2014-08-19profiles: Add 'manifest-transaction'....Alex Kost 2014-08-12profiles: Add 'manifest-add'....Alex Kost 2014-07-26profiles: Add 'package->manifest-entry'....Ludovic Courtès 2014-07-26profiles: Switch to gexps....Ludovic Courtès 2013-11-01guix package: Allow removal of a specific package output....Ludovic Courtès