aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-03-25 17:32:33 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-04-08 17:31:12 +0200
commit7d5baa300dbad8d4d9041f75dc063b4ac2d18064 (patch)
tree2b2013a58339f59f8c2f5edb8c27a63c0d44f887 /gnu/packages/haskell.scm
parent042bc828fcd2dc7bbacbe6ef0408722a3d51a684 (diff)
downloadguix-7d5baa300dbad8d4d9041f75dc063b4ac2d18064.tar.gz
guix-7d5baa300dbad8d4d9041f75dc063b4ac2d18064.zip
gnu: Add ghc-mtl.
* gnu/packages/haskell.scm: (ghc-mtl): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index beecccb3bf..d02c5f946a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -23,6 +23,7 @@
#:use-module (guix download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system haskell)
#:use-module (gnu packages perl)
#:use-module (gnu packages elf)
#:use-module (gnu packages bootstrap)
@@ -225,4 +226,31 @@
interactive environment for the functional language Haskell.")
(license bsd-3)))
+(define-public ghc-mtl
+ (package
+ (name "ghc-mtl")
+ (version "2.1.3.1")
+ (outputs '("out" "doc"))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/mtl/mtl-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1xpn2wjmqbh2cg1yssc6749xpgcqlrrg4iilwqgkcjgvaxlpdbvp"))))
+ (build-system haskell-build-system)
+ (home-page "http://github.com/ekmett/mtl")
+ (synopsis
+ "Monad classes, using functional dependencies")
+ (description
+ "Monad classes using functional dependencies, with instances
+for various monad transformers, inspired by the paper
+'Functional Programming with Overloading and Higher-Order Polymorphism',
+by Mark P Jones, in 'Advanced School of Functional Programming', 1995
+http://web.cecs.pdx.edu/~mpj/pubs/springschool.html.")
+ (license bsd-3)))
+
;;; haskell.scm ends here