aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-05-13 09:34:35 +0200
committerLars-Dominik Braun <lars@6xq.net>2023-05-13 09:34:35 +0200
commitcf89a215cec346bc4d6622cbe353c058452b29b2 (patch)
treeb1ccd815924ff700c46fc9b5c8a72c6f3a955114 /gnu/packages/haskell-check.scm
parentd67a3622ef82b68ee40a2c93abe3d1478633719c (diff)
downloadguix-cf89a215cec346bc4d6622cbe353c058452b29b2.tar.gz
guix-cf89a215cec346bc4d6622cbe353c058452b29b2.zip
gnu: ghc-tasty: Add missing dependency on i686-linux.
Fixes <https://issues.guix.gnu.org/63421>. * gnu/packages/haskell-check.scm (ghc-tasty)[inputs]: Conditionally add ghc-unbounded-delays.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 23727fc0b8..da05582400 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -148,7 +148,13 @@ contains the correct result for the test.")
"006bf4gyc30i2gvb17hj1mzrh1kwnwf7l050x3f72wi6c2axl87l"))))
(build-system haskell-build-system)
(properties '((upstream-name . "tasty")))
- (inputs (list ghc-tagged ghc-optparse-applicative ghc-ansi-terminal))
+ (inputs
+ (append
+ (list ghc-tagged ghc-optparse-applicative ghc-ansi-terminal)
+ ;; TODO: Add ghc-unbounded-delays unconditionally on next rebuild cycle.
+ (if (member (%current-system) '("i686-linux"))
+ (list ghc-unbounded-delays)
+ '())))
(home-page "https://github.com/UnkindPartition/tasty")
(synopsis "Modern and extensible testing framework")
(description