aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-09-21 15:13:23 +0200
committerMark H Weaver <mhw@netris.org>2014-09-23 18:52:26 -0400
commit99462faca02735ddafec252cf89b44b95f87368a (patch)
tree96283eee2c10363683906528e1450ca1547ac636 /gnu/packages/gtk.scm
parent4627a4647018fa8d5c2fa4ec60971497583f8606 (diff)
downloadguix-99462faca02735ddafec252cf89b44b95f87368a.tar.gz
guix-99462faca02735ddafec252cf89b44b95f87368a.zip
gnu: gtk+: Remove dependency on Xorg server on mips64el-linux.
Reported by Mark H. Weaver. * gnu/packages/gtk.scm (gtk+)[native-inputs]: Remove XORG-SERVER on mips64el-linux.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 0a6499d293..0cbd55dd52 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -404,7 +404,13 @@ application suites.")
("pkg-config" ,pkg-config)
("gobject-introspection" ,gobject-introspection)
("python-wrapper" ,python-wrapper)
- ("xorg-server" ,xorg-server)))
+
+ ;; FIXME: The Xorg server is needed to run the tests, but it currently
+ ;; fails to build on mips64el, so remove it in the meantime.
+ ,@(if (string=? (or (%current-target-system) (%current-system))
+ "mips64el-linux")
+ '()
+ `(("xorg-server" ,xorg-server)))))
(arguments
`(#:phases
(alist-replace