aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-04-24 21:31:58 +0300
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:01 +0200
commit0bae9e17c681bec70424f921e004808b390fe892 (patch)
tree0d0d3c5df3b6c4bc5b8d16040c4a81998c4faf0d /gnu/packages/gtk.scm
parent3d4efef46da5c7442ce17ceaf41d87d84ef928bd (diff)
downloadguix-0bae9e17c681bec70424f921e004808b390fe892.tar.gz
guix-0bae9e17c681bec70424f921e004808b390fe892.zip
gnu: at-spi2-core: Honor the #:tests? flag.
* gnu/packages/gtk.scm (at-spi2-core)[arguments]: Adjust the 'check phase to honor the #:tests? flag. Skip the tests when building for powerpc-linux. Change-Id: Ia1fc275ebca5d69b851b566ae7afb47fdad8f066
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm55
1 files changed, 26 insertions, 29 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index c16eaea8ef..6be87e9472 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -831,38 +831,35 @@ ever use this library.")
(arguments
(list
#:glib-or-gtk? #t ;to wrap binaries and/or compile schemas
+ #:tests? (not (or (target-ppc32?)
+ (%current-target-system)))
#:phases
#~(modify-phases %standard-phases
(delete 'check)
- ;; The CI test suite fails completely on powerpc-linux.
- ;; The name org.gnome.SessionManager was not provided by any .service
- ;; TODO: Wrap 'check phase with 'tests?'.
- #$@(if (not (or (target-ppc32?)
- (%current-target-system)))
- #~((add-after 'install 'check
- (lambda _
- ;; xfconfd requires a writable HOME
- (setenv "HOME" (getenv "TMPDIR"))
- ;; dbus-run-session may crash if XDG_DATA_DIRS has too
- ;; many entries, maybe related to
- ;; https://gitlab.freedesktop.org/dbus/dbus/-/issues/481.
- (setenv "XDG_DATA_DIRS"
- (string-append
- #$output "/share:"
- #$(this-package-native-input
- "gsettings-desktop-schemas")
- "/share"))
- ;; Don't fail on missing '/etc/machine-id'.
- (setenv "DBUS_FATAL_WARNINGS" "0")
- (with-directory-excursion (string-append "../at-spi2-core-"
- #$version "")
- (invoke "dbus-run-session" "--" "ci/run-registryd-tests.sh")
- (substitute* "ci/run-tests.sh"
- (("ps auxwww") "") ;avoid a dependency on procps
- (("meson test -C _build")
- "meson test -C ../build")) ;adjust build directory
- (invoke "dbus-run-session" "--" "ci/run-tests.sh")))))
- #~()))))
+ (add-after 'install 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; xfconfd requires a writable HOME
+ (setenv "HOME" (getenv "TMPDIR"))
+ ;; dbus-run-session may crash if XDG_DATA_DIRS has too
+ ;; many entries, maybe related to
+ ;; https://gitlab.freedesktop.org/dbus/dbus/-/issues/481.
+ (setenv "XDG_DATA_DIRS"
+ (string-append
+ #$output "/share:"
+ #$(this-package-native-input
+ "gsettings-desktop-schemas")
+ "/share"))
+ ;; Don't fail on missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (with-directory-excursion (string-append "../at-spi2-core-"
+ #$version "")
+ (invoke "dbus-run-session" "--" "ci/run-registryd-tests.sh")
+ (substitute* "ci/run-tests.sh"
+ (("ps auxwww") "") ;avoid a dependency on procps
+ (("meson test -C _build")
+ "meson test -C ../build")) ;adjust build directory
+ (invoke "dbus-run-session" "--" "ci/run-tests.sh"))))))))
(inputs
(list bash-minimal libxml2))
(propagated-inputs