aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-08-13 00:45:51 +0300
committerLudovic Courtès <ludo@gnu.org>2024-08-31 19:06:38 +0200
commit7aecfa94624de88ee13bf4e77829d70bde09d4e1 (patch)
tree1013d5a22c0b9ac7fb46e1f917335902ef0065ef /gnu/packages/graphics.scm
parent98545ea11558cf6c230dfaebdd0af2acd50e0f43 (diff)
downloadguix-7aecfa94624de88ee13bf4e77829d70bde09d4e1.tar.gz
guix-7aecfa94624de88ee13bf4e77829d70bde09d4e1.zip
gnu: mmm: Fix the build.
* gnu/packages/graphics.scm (mmm): Fix the build. [arguments]: Add "patch-meson-build" phase. [home-page]: Fix the URL. Change-Id: If6f1a255e864669a10c646ee0d991e6fabdcb6b9 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 61a9f8a92e..47951e55f9 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -162,6 +162,16 @@
(sha256
(base32 "1xmcv6rwinqsbr863rgl9005h2jlmd7k2qrwsc1h4fb8r61ykpjl"))))
(build-system meson-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ ;; XXX: Meson build fails due to a misspelling of
+ ;; "description" keyword in the configuration. This phase
+ ;; fixes that.
+ (add-after 'unpack 'patch-meson-build
+ (lambda _
+ (substitute* "meson.build"
+ (("not stable, Description:")
+ "not stable, description:")))))))
(native-inputs
(list luajit pkg-config))
(inputs
@@ -169,7 +179,7 @@
(synopsis "Memory Mapped Machine")
(description "MMM is a shared memory protocol for virtualising access to
framebuffer graphics, audio output and input event.")
- (home-page "https://github.com/hodefoting/mrg")
+ (home-page "https://github.com/hodefoting/mmm")
(license license:isc)))
(define-public directfb