aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2024-07-18 19:09:44 -0400
committerLudovic Courtès <ludo@gnu.org>2024-07-20 12:12:16 +0200
commit2aa3903fdbc36d694d714b79e2ade8da695e7237 (patch)
tree8883ba8cd3f1c5e0bc848636035017d0789dd38d /gnu/packages/gps.scm
parentde0fbfbf0b5af78177e0fc6c5de519219f1c0a71 (diff)
downloadguix-2aa3903fdbc36d694d714b79e2ade8da695e7237.tar.gz
guix-2aa3903fdbc36d694d714b79e2ade8da695e7237.zip
gnu: gpxsee: Update to 13.22.
* gnu/packages/gps.scm (gpxsee): Update to 13.22. Use qt-build-system. Use qt6 instead of qt5. Change-Id: I9101a6f763be198549aca8e5aea95987b14e58e4 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm52
1 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index ce7e4bfbe3..ebb7eed99c 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -31,6 +31,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system scons)
+ #:use-module (guix build-system qt)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
#:use-module (gnu packages)
@@ -51,6 +52,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages serialization)
#:use-module (gnu packages sqlite)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml))
(define-public gpsbabel
@@ -179,33 +181,31 @@ coordinates as well as partial support for adjustments in global coordinate syst
(define-public gpxsee
(package
(name "gpxsee")
- (version "11.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tumic0/GPXSee")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1klpjiqsvpvhlg5hsfjaszsyqr817hig9r7y7w4cp0kyn8z5fzfj"))))
- (build-system gnu-build-system)
+ (version "13.22")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tumic0/GPXSee")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15m5rqky2fwsq5n6x531350x39wwhpv1hz56m1yfaxj7acxhb2p5"))))
+ (build-system qt-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'configure
- ;; Use lrelease to convert TS translation files into QM files.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (for-each (lambda (file)
- (invoke "lrelease" file))
- (find-files "lang" "\\.ts"))
- (invoke "qmake"
- (string-append "PREFIX="
- (assoc-ref outputs "out"))))))))
- (inputs
- (list qtbase-5 qtlocation-5 qtsvg-5))
- (native-inputs
- (list qttools-5))
+ (list
+ #:qtbase qtbase
+ #:tests? #f ; no tests
+ #:phases #~(modify-phases %standard-phases
+ (replace 'configure
+ ;; Use lrelease to convert TS translation files into QM files.
+ (lambda _
+ (apply invoke "lrelease"
+ (find-files "lang" "\\.ts"))
+ (invoke "qmake"
+ (string-append "PREFIX=" #$output)))))))
+ (inputs (list libxkbcommon qtbase qtpositioning qtserialport qtsvg))
+ (native-inputs (list qttools))
(home-page "https://www.gpxsee.org")
(synopsis "GPS log file viewer and analyzer")
(description