aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-28 23:48:58 +0000
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-12-01 10:27:37 +0300
commitf9f6ca8c54d48b4a53e86568902806999a04232e (patch)
tree07602b508357d5a6bb1fe03f82c58f0c27e36eff /gnu/packages/golang.scm
parent703951b157db1c413f8718644d3c1e20f5ec5e1b (diff)
downloadguix-f9f6ca8c54d48b4a53e86568902806999a04232e.tar.gz
guix-f9f6ca8c54d48b4a53e86568902806999a04232e.zip
gnu: Add go-github-com-kylelemons-godebug-pretty.
* gnu/packages/golang.scm (go-github-com-kylelemons-godebug-pretty): New variable. Change-Id: Icd7d5fd70cf56d1ca74e9a2cfb929a3344128ba7 Reviewed-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6b78b19cc5..541ac453d4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4722,6 +4722,16 @@ structure. It can also produce a much more verbose, one-item-per-line
representation suitable for computing diffs.")
(license license:asl2.0)))
+;; TODO: Merge with go-github-com-kylelemons-godebug and provide both module;
+;; for go-team.
+(define-public go-github-com-kylelemons-godebug-pretty
+ (package
+ (inherit go-github-com-kylelemons-godebug)
+ (name "go-github-com-kylelemons-godebug-pretty")
+ (arguments
+ '(#:import-path "github.com/kylelemons/godebug/pretty"
+ #:unpack-path "github.com/kylelemons/godebug"))))
+
(define-public go-github-com-kr-text
(package
(name "go-github-com-kr-text")