aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-14 22:35:21 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:47 +0000
commite6cc3a4743807a38eeebd032d4395aa22588e2f7 (patch)
tree7255597147e5e9c13522b350e8adfe2e54d9fecb /gnu/packages/golang.scm
parent9399db35c2105157407fd4a59aeb0cacc58a0c54 (diff)
downloadguix-e6cc3a4743807a38eeebd032d4395aa22588e2f7.tar.gz
guix-e6cc3a4743807a38eeebd032d4395aa22588e2f7.zip
gnu: go-github-com-go-git-go-billy-v5: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-go-git-go-billy-v5): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I40d1c024b52f0530a80657d5a2416b244447be93
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7d6e3d2371..cb11fefb5a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6056,37 +6056,6 @@ errors (warnings).")
(description "Gcfg reads INI-style configuration files into Go structs.")
(license license:bsd-3)))
-(define-public go-github-com-go-git-go-billy-v5
- (package
- (name "go-github-com-go-git-go-billy-v5")
- (version "5.5.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/go-git/go-billy")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1r7hfwc6lqnb7jhbbmicdlb3yipjyazq3pndpffw026fcq7jhxg1"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/go-git/go-billy/v5"))
- (propagated-inputs
- (list go-github-com-cyphar-filepath-securejoin
- go-golang-org-x-sys))
- (native-inputs
- (list go-github-com-onsi-gomega
- go-gopkg-in-check-v1))
- (home-page "https://github.com/go-git/go-billy/")
- (synopsis "File system abstraction for Go")
- (description "Billy implements an interface based on the OS's standard
-library to develop applications without depending on the underlying storage.
-This makes it virtually free to implement mocks and testing over
-file system operations.")
- (license license:asl2.0)))
-
(define-public go-github-com-jba-templatecheck
(package
(name "go-github-com-jba-templatecheck")