aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2023-06-18 12:43:10 +0900
committerLudovic Courtès <ludo@gnu.org>2023-06-21 00:10:50 +0200
commitda4305e9b3d65cf698a6987bd7be7905785bf06c (patch)
tree10ffa3ba8972dc56820bf681d765f3d6215f1bf9 /gnu/packages/golang.scm
parentd67c85324dedcc33a56b146c8a51b5eec83aafe9 (diff)
downloadguix-da4305e9b3d65cf698a6987bd7be7905785bf06c.tar.gz
guix-da4305e9b3d65cf698a6987bd7be7905785bf06c.zip
gnu: go-github-com-mattn-go-runewidth: Update to 0.0.14.
* gnu/packages/golang.scm (go-github-com-mattn-go-runewidth): Update to 0.0.14. (go-github.com-mattn-go-runewidth): Remove, and change users to to refer to 'go-github-com-mattn-go-runewidth'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d51c023808..b99659966d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2755,7 +2755,7 @@ jar struct to manage the cookies added to the cookie jar.")
'(#:unpack-path "github.com/gizak/termui"
#:import-path "github.com/gizak/termui/v3"))
(propagated-inputs
- (list go-github.com-mattn-go-runewidth
+ (list go-github-com-mattn-go-runewidth
go-github-com-mitchellh-go-wordwrap go-github.com-nsf-termbox-go))
(home-page "https://github.com/gizak/termui")
(synopsis "Terminal dashboard widget Go library")
@@ -7105,7 +7105,7 @@ encoding in Go.")
(arguments
`(#:import-path "github.com/gdamore/tcell"))
(inputs
- (list go-github.com-mattn-go-runewidth
+ (list go-github-com-mattn-go-runewidth
go-github-com-lucasb-eyer-go-colorful
go-golang-org-x-text
go-github-com-gdamore-encoding))
@@ -9128,7 +9128,7 @@ transforms one JSON document into another through a JMESPath expression.")
`(#:import-path "github.com/muesli/reflow/wordwrap"
#:unpack-path "github.com/muesli/reflow"))
(native-inputs
- (list go-github.com-mattn-go-runewidth))
+ (list go-github-com-mattn-go-runewidth))
(home-page "https://github.com/muesli/reflow/")
(synopsis "Collection of methods helping to transform blocks of text")
(description "This package provides a collection of ANSI-aware methods and
@@ -9187,7 +9187,7 @@ io.Writers helping you to transform blocks of text.")
(list go-github-com-google-goterm
go-github-com-lucasb-eyer-go-colorful
go-github-com-mattn-go-isatty
- go-github.com-mattn-go-runewidth))
+ go-github-com-mattn-go-runewidth))
(home-page "https://github.com/muesli/termenv/")
(synopsis "Advanced styling options on the terminal")
(description "termenv lets you safely use advanced styling options on the
@@ -9241,7 +9241,7 @@ which produce colorized output using github.com/fatih/color.")
(arguments
`(#:import-path "github.com/olekukonko/tablewriter"))
(propagated-inputs
- (list go-github.com-mattn-go-runewidth))
+ (list go-github-com-mattn-go-runewidth))
(home-page "https://github.com/olekukonko/tablewriter/")
(synopsis "Generate ASCII table")
(description "This package generates ASCII tables. Features:
@@ -9338,7 +9338,7 @@ size of the terminal.")
go-github-com-muesli-reflow-wordwrap
go-github-com-muesli-reflow-indent
go-github-com-muesli-reflow-padding
- go-github.com-mattn-go-runewidth
+ go-github-com-mattn-go-runewidth
go-github-com-muesli-termenv
go-github-com-google-goterm
go-github-com-lucasb-eyer-go-colorful
@@ -11521,7 +11521,7 @@ averages.")
(define-public go-github-com-mattn-go-runewidth
(package
(name "go-github-com-mattn-go-runewidth")
- (version "0.0.13")
+ (version "0.0.14")
(source
(origin
(method git-fetch)
@@ -11530,7 +11530,7 @@ averages.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1yir0f3wc5z5hnkwhvx5qb6nmpfb05zp2gvfjvna63s8kmla1rrn"))))
+ (base32 "1iaqw5pd7f4f2xz37540kp0828p2820g4vxx3hz089hwl331sx1v"))))
(build-system go-build-system)
(arguments '(#:import-path "github.com/mattn/go-runewidth"))
(propagated-inputs
@@ -11563,7 +11563,7 @@ string.")
(propagated-inputs
`(("github.com/mattn/go-isatty" ,go-github-com-mattn-go-isatty)
("github.com/muesli/termenv" ,go-github-com-muesli-termenv)
- ("github.com/mattn/go-runewidth" ,go-github.com-mattn-go-runewidth)
+ ("github.com/mattn/go-runewidth" ,go-github-com-mattn-go-runewidth)
("go-github-com-muesli-reflow-indent" ,go-github-com-muesli-reflow-indent)
("go-github-com-muesli-reflow-ansi" ,go-github-com-muesli-reflow-ansi)
("go-github-com-lucasb-eyer-go-colorful" ,go-github-com-lucasb-eyer-go-colorful)