aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-21 12:52:32 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:00:59 +0100
commitd43795cd208161495391104054e36abb94ea0a89 (patch)
treeb143dbd36c52a8bfa44df4c27127072ae0c35423 /gnu/packages/golang.scm
parent3750e11a8dfb0ae9f34db348e4d7cd7ce1e16e26 (diff)
downloadguix-d43795cd208161495391104054e36abb94ea0a89.tar.gz
guix-d43795cd208161495391104054e36abb94ea0a89.zip
gnu: go-github-com-golang-protobuf: Move to golang-build.
* gnu/packages/golang.scm (go-github-com-golang-protobuf): Move from here ... * gnu/packages/golang-build.scm: ... to here. Change-Id: I1682e199e6acd6b8362deff47fa7a26cbfe9c9ea
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm34
1 files changed, 0 insertions, 34 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4ca8c87cb2..92c0d0edbd 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6166,40 +6166,6 @@ test results.")
(home-page "https://github.com/gotestyourself/gotestsum")
(license license:asl2.0)))
-(define-public go-github-com-golang-protobuf
- (package
- (name "go-github-com-golang-protobuf")
- (version "1.5.3")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/golang/protobuf")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "03f1w2cd4s8a3xhl61x7yjx81kbzlrjpvnnwmbhqnz814yi7h43i"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/golang/protobuf"
- #:phases
- #~(modify-phases %standard-phases
- ;; XXX: Workaround for go-build-system's lack of Go modules
- ;; support.
- (delete 'build)
- (replace 'check
- (lambda* (#:key tests? import-path #:allow-other-keys)
- (when tests?
- (with-directory-excursion (string-append "src/" import-path)
- (invoke "go" "test" "-v" "./..."))))))))
- (propagated-inputs
- (list go-google-golang-org-protobuf))
- (synopsis "Go support for Protocol Buffers")
- (description "This package provides Go support for the Protocol Buffers
-data serialization format.")
- (home-page "https://github.com/golang/protobuf")
- (license license:bsd-3)))
-
(define-public go-github-com-macronut-go-tproxy
(package
(name "go-github-com-macronut-go-tproxy")