aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:40 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:38:56 -0500
commitbd0898a9cce91e9db742800b98cde15d722510d3 (patch)
tree54a398e8200fd9b6bb71a295fc08948a43a6ea6e /gnu/packages/golang.scm
parent236ae7820e8ee6071975ee880a586a36751ecf13 (diff)
downloadguix-bd0898a9cce91e9db742800b98cde15d722510d3.tar.gz
guix-bd0898a9cce91e9db742800b98cde15d722510d3.zip
gnu: go-github-com-google-go-github: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-google-go-github): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: I17711a8f0bfd58a12cf805f1678688d2946c985b
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index add75b11d2..0d83c2b270 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7987,32 +7987,6 @@ and from termios translations, readCh, reading passwords, etc.")
into URL query parameters.")
(license license:bsd-3))))
-(define-public go-github-com-google-go-github
- (package
- (name "go-github-com-google-go-github")
- (version "26.1.3")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/go-github")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0x0zz1vcmllp6r6l2qin9b2llm5cxbf6n84rf99h8wrmhvzs2ipi"))))
- (build-system go-build-system)
- (arguments
- `(#:tests? #f ;application/octet-stream instead of text/plain
- #:import-path "github.com/google/go-github/v26/github"
- #:unpack-path "github.com/google/go-github/v26"))
- (native-inputs
- (list go-github-com-google-go-querystring go-golang-org-x-crypto))
- (home-page "https://github.com/google/go-github/")
- (synopsis "Client library for accessing the GitHub API v3")
- (description "@code{go-github} is a Go client library for accessing the
-GitHub API v3.")
- (license license:bsd-3)))
-
(define-public go-github-com-google-renameio
(package
(name "go-github-com-google-renameio")