aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:34:40 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:13 -0500
commita0006c4dc5354c703c74b7561a3e7866297e95dd (patch)
tree103930842283716109bec4435c66a1db6bf5bc7a /gnu/packages/golang.scm
parentd14389f10ec8c7e4c0a91c1c5094befc4445ddf0 (diff)
downloadguix-a0006c4dc5354c703c74b7561a3e7866297e95dd.tar.gz
guix-a0006c4dc5354c703c74b7561a3e7866297e95dd.zip
gnu: go-github-com-gorilla-mux: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-gorilla-mux): Move from here... * gnu/packages/golang-web.scm: ...to here. * gnu/packages/finance.scm: Add (gnu packages golang-web) module. * gnu/packages/web.scm: As above... Change-Id: I1cb94377d581af93593dbb29cb60ddf5fb287ada
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index fb77f610e7..edc8c2bec0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4862,30 +4862,6 @@ containers.")
(description "This package provides @code{gorilla/context}, which is a general purpose registry for global request variables in the Go programming language.")
(license license:bsd-3))))
-(define-public go-github-com-gorilla-mux
- (package
- (name "go-github-com-gorilla-mux")
- (version "1.8.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gorilla/mux")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "18f0q9qxgq1yh4ji07mqhiydfcwvi56z9d775v7dc7yckj33kpdk"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/gorilla/mux"))
- (home-page "https://github.com/gorilla/mux")
- (synopsis "URL router and dispatcher for Go")
- (description
- "Gorilla/Mux implements a request router and dispatcher for matching
-incoming requests with their respective handler.")
- (license license:bsd-3)))
-
(define-public go-github-com-andybalholm-brotli
(package
(name "go-github-com-andybalholm-brotli")