aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-14 23:23:14 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:47 +0000
commit8861d9e1d0019a07d65cebe1d310404378843e00 (patch)
treec7506fc117a9a65fd0585544bd9e8623baef2fc8 /gnu/packages/golang.scm
parentd80979ce690bbac8566b7250e5abdf9fb88238dc (diff)
downloadguix-8861d9e1d0019a07d65cebe1d310404378843e00.tar.gz
guix-8861d9e1d0019a07d65cebe1d310404378843e00.zip
gnu: Add go-github-com-bmatcuk-doublestar-v3.
* gnu/packages/golang.scm (go-github-com-bmatcuk-doublestar-v3): New variable. Change-Id: I5d629750abef81f1b4f5ec8bb0cdb0e2f219d3e2
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cb11fefb5a..8887e36da2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5760,7 +5760,7 @@ maps (because they are not addressable using Go reflection).")
matching and globbing with support for \"doublestar\" patterns.")
(license license:expat)))
-;; For chezmoi-1.8.10
+;; For chezmoi-1.8.11
(define-public go-github-com-bmatcuk-doublestar-v2
(package
(inherit go-github-com-bmatcuk-doublestar)
@@ -5781,6 +5781,25 @@ matching and globbing with support for \"doublestar\" patterns.")
#:unpack-path "github.com/bmatcuk/doublestar/v2"
#:import-path "github.com/bmatcuk/doublestar/v2"))))
+(define-public go-github-com-bmatcuk-doublestar-v3
+ (package
+ (inherit go-github-com-bmatcuk-doublestar)
+ (name "go-github-com-bmatcuk-doublestar-v3")
+ (version "3.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bmatcuk/doublestar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "011h07mlmscbxxjr3h30fjjb4dw3gb245nzczaq520r112xlidhj"))))
+ (arguments
+ (list
+ #:tests? #f ; tests have more broken parts
+ #:import-path "github.com/bmatcuk/doublestar/v3"))))
+
(define-public go-github-com-bmatcuk-doublestar-v4
(package
(inherit go-github-com-bmatcuk-doublestar)