aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-13 11:03:09 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:44 +0000
commit87e551680e3c3b95e37967a0be8579b9161a8315 (patch)
tree74fe1a859231c46d8293e3fa6bd507a5d9ff2dd6 /gnu/packages/golang.scm
parent2260ff7393ad8bbacdaef9b6e5df45d308b159aa (diff)
downloadguix-87e551680e3c3b95e37967a0be8579b9161a8315.tar.gz
guix-87e551680e3c3b95e37967a0be8579b9161a8315.zip
gnu: go-github-com-google-goterm: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-google-goterm): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I9f97ecc4a8b4c19cae3766bfed6368bbb74cb439
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f1f8405ceb..a51cdf59ac 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5369,32 +5369,6 @@ a cron spec parser and job runner.")
"This package provides packet processing capabilities for Go.")
(license license:bsd-3)))
-(define-public go-github-com-google-goterm
- (package
- (name "go-github-com-google-goterm")
- (version "0.0.0-20200907032337-555d40f16ae2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/goterm")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0809sf02dhg2bjhsz43pmlb5d7nbsnwxls3lw01zw5p7ri9bqwfb"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/google/goterm/term"
- #:unpack-path "github.com/google/goterm"))
- (home-page "https://github.com/google/goterm/")
- (synopsis "PTY creation and termios get/set attributes")
- (description
- "The term package implements PTY creation and termios get/set attributes.
-It also contains some convenience functions for colors, SSH to and from
-termios translations, readCh, reading passwords, etc.")
- (license license:bsd-3)))
-
(define (go-gotest-tools-source version sha256-base32-hash)
(origin
(method git-fetch)