aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-13 11:49:15 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:45 +0000
commit55e77705c4e35f945729a00d60fcebe17fc2e770 (patch)
tree21f006c8bf8d06120b849ffa1d6a21cf1a7eadb8 /gnu/packages/golang.scm
parenta2a6f0dd82ac107fd441227dc2f0778497534a14 (diff)
downloadguix-55e77705c4e35f945729a00d60fcebe17fc2e770.tar.gz
guix-55e77705c4e35f945729a00d60fcebe17fc2e770.zip
gnu: go-github-com-jonboulle-clockwork: Update to 0.4.0.
* gnu/packages/golang.scm (go-github-com-jonboulle-clockwork): Update to 0.4.0. Change-Id: I75f231341968fe3941c6459055fb554f6e77a782
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a9151e33be..6be2a16eea 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3239,21 +3239,19 @@ containers.")
(license license:asl2.0))))
(define-public go-github-com-jonboulle-clockwork
- (let ((commit "e3653ace2d63753697e0e5b07b9393971c0bba9d")
- (revision "0"))
(package
(name "go-github-com-jonboulle-clockwork")
- (version (git-version "0.0.0" revision commit))
+ (version "0.4.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/jonboulle/clockwork")
- (commit commit)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "1avzqhks12a8x2yzpvjsf3k0gv9cy7zx2z88hn0scacnxkphisvc"))))
+ "1j1k9chzy5pb76r4r1k0vr5fbkvna564v6dzjflhapwsr7jpjgwf"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/jonboulle/clockwork"))
@@ -3262,7 +3260,7 @@ containers.")
(description
"Replace uses of the @code{time} package with the
@code{clockwork.Clock} interface instead.")
- (license license:asl2.0))))
+ (license license:asl2.0)))
(define-public go-github-com-spf13-afero
(package