aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-19 02:29:09 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 22:17:30 -0400
commit4e65fb5b336197c0f20aba76ba8e44e9197a7a5b (patch)
treee5cbeae3bfb8e959b68086bbc9cef5914206c1bf /gnu/packages/golang.scm
parentcf9c76223f028dce92bfe5b242a4faeba73f9d02 (diff)
downloadguix-4e65fb5b336197c0f20aba76ba8e44e9197a7a5b.tar.gz
guix-4e65fb5b336197c0f20aba76ba8e44e9197a7a5b.zip
gnu: go-honnef-co-go-tools: Move to (gnu packages golang-check).
* gnu/packages/golang-check.scm (go-honnef-co-go-tools): Move from here... * gnu/packages/golang.scm: ... to here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3ff544a67b..2503fca0b6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11529,37 +11529,6 @@ reformat the source code, it only prints out style mistakes.")
tools with similar semantics.")
(license license:expat)))
-(define-public go-honnef-co-go-tools
- (package
- (name "go-honnef-co-go-tools")
- (version "0.3.3")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dominikh/go-tools")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "099z04v7vvwwglnps315s9fmal68xvzlc1g8m26iqi980grbwn32"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "honnef.co/go/tools"
- #:tests? #f
- ;; Source-only package
- #:phases (modify-phases %standard-phases
- (delete 'build))))
- (propagated-inputs (list go-golang-org-x-exp go-golang-org-x-tools
- go-golang-org-x-mod go-github-com-kisielk-gotool
- go-github-com-burntsushi-toml))
- (home-page "https://honnef.co/go/tools")
- (synopsis "Staticcheck advanced Go linter")
- (description
- "Staticcheck is a state of the art linter for the Go programming language.
-Using static analysis, it finds bugs and performance issues, offers
-simplifications, and enforces style rules.")
- (license license:expat)))
-
(define-public go-go-uber-org-zap
(package
(name "go-go-uber-org-zap")