aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-14 22:04:48 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:46 +0000
commit43a8d07d22abef20515bfacd981654cf77f6f6b2 (patch)
tree3fe7dfa2b13adb5acec3d288e09984aaa5edff6a /gnu/packages/golang.scm
parent8509c5e659c8a6ec91d370b06067560922cf119e (diff)
downloadguix-43a8d07d22abef20515bfacd981654cf77f6f6b2.tar.gz
guix-43a8d07d22abef20515bfacd981654cf77f6f6b2.zip
gnu: go-github-com-go-git-go-git-fixtures: Update to 4.3.1.
* gnu/packages/golang.scm (go-github-com-go-git-go-git-fixtures): Update to 4.3.1. [propagated-inputs]: Add go-github-com-go-git-go-billy and go-gopkg-in-check-v1. [native-inputs]: Remove go-github-com-alcortesm-tgz, go-github-com-go-git-go-billy, go-golang-org-x-sys, and go-gopkg-in-check-v1; add go-github-com-stretchr-testify. Change-Id: Ibe88981fd0dfc45651d7d4fa1f42a82f54472468
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3abf668a02..0bc3167f19 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6228,7 +6228,7 @@ temporal directories.")
(define-public go-github-com-go-git-go-git-fixtures
(package
(name "go-github-com-go-git-go-git-fixtures")
- (version "4.0.1")
+ (version "4.3.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -6237,7 +6237,7 @@ temporal directories.")
(file-name (git-file-name name version))
(sha256
(base32
- "002yb1s2mxq2xijkl39ip1iyc3l52k23ikyi9ijfl4bgqxy79ljg"))))
+ "1d6qs2mzbhz95aflpjh6ijywvb4ys73jvk2v30mickax3gmm2vlw"))))
(build-system go-build-system)
(arguments
(list
@@ -6248,8 +6248,10 @@ temporal directories.")
#~(modify-phases %standard-phases
(delete 'reset-gzip-timestamps))))
(native-inputs
- (list go-github-com-alcortesm-tgz go-github-com-go-git-go-billy
- go-golang-org-x-sys go-gopkg-in-check-v1))
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-go-git-go-billy
+ go-gopkg-in-check-v1))
(home-page "https://github.com/go-git/go-git-fixtures/")
(synopsis "Fixtures used by @code{go-git}")
(description "This package provides fixtures used by @code{go-git}.")