aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-02-11 12:03:56 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 21:26:39 +0000
commit2525b168f98066c1400783c1f350c90ec1259a76 (patch)
tree33ed1325774968e6f1f85702c7f1205985855408 /gnu/packages/golang.scm
parent0f19437ab8c1c4b6e26cdd78ba89f1a0cd18b86b (diff)
downloadguix-2525b168f98066c1400783c1f350c90ec1259a76.tar.gz
guix-2525b168f98066c1400783c1f350c90ec1259a76.zip
gnu: go-github-com-avast-retry-go: Remove examples.
* gnu/packages/golang.scm (go-github-com-avast-retry-go): Remove examples. [arguments] <#:phases>: Add remove-examples phase. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I20107aa3c77add0f5645f8f3be5ca45de9ab1ed9
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7daeaa1c86..50a73a1ae3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1264,7 +1264,14 @@ cluster segmentation algorithm.")
(sha256
(base32 "0hb4b1668516a4gv8avmflr565b6c1h93phdb068hcjxxj8767ba"))))
(build-system go-build-system)
- (arguments `(#:import-path "github.com/avast/retry-go"))
+ (arguments
+ (list
+ #:import-path "github.com/avast/retry-go"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-examples
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/examples")))))))
(propagated-inputs (list go-github-com-stretchr-testify))
(home-page "https://github.com/avast/retry-go")
(synopsis "Simple golang library for retry mechanism")