aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 11:22:07 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:01:03 +0100
commit0b898c594c0eb8e7621e6412ddf6d93af20848e6 (patch)
tree78909e439ae765231f0e0716b02993d9c359b828 /gnu/packages/golang.scm
parent0e823e011ea0314069208dce78e89438dfde9118 (diff)
downloadguix-0b898c594c0eb8e7621e6412ddf6d93af20848e6.tar.gz
guix-0b898c594c0eb8e7621e6412ddf6d93af20848e6.zip
gnu: go-github-com-prometheus-procfs: Move to prometheus.
* gnu/packages/golang.scm (go-github-com-prometheus-procfs): Move from here ... * gnu/packages/prometheus.scm: ... to here. Remove (gnu packages golang) module. * gnu/packages/golang.scm: Remove (gnu packages prometheus) module. * gnu/packages/prometheus.scm: Remove (gnu packages golang) module. Change-Id: I3dd26ebc80c0a9fad47cec9887d6f52ad21bdc45
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a81c4f8d02..3acc5588a5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -96,7 +96,6 @@
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
- #:use-module (gnu packages prometheus)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages ruby)
#:use-module (gnu packages terminals)
@@ -7349,35 +7348,6 @@ system.")
formatting information, rather than the current locale name.")
(license license:expat))))
-(define-public go-github-com-prometheus-procfs
- (package
- (name "go-github-com-prometheus-procfs")
- (version "0.15.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/prometheus/procfs")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "116ns8k1yjdj9a2vq5czlpmafrhy0yw5y0bcm1qqbqnn57agg68m"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/prometheus/procfs"
- ;; The tests require Go modules, which are not yet supported in Guix's
- ;; Go build system.
- #:tests? #f))
- (propagated-inputs
- (list go-github-com-google-go-cmp
- go-golang-org-x-sync
- go-golang-org-x-sys))
- (synopsis "Go library for reading @file{/proc}")
- (description "The @code{procfs} Go package provides functions to retrieve
-system, kernel, and process metrics from the @file{/proc} pseudo file system.")
- (home-page "https://github.com/prometheus/procfs")
- (license license:asl2.0)))
-
(define-public go-github-com-zalando-go-keyring
(package
(name "go-github-com-zalando-go-keyring")