aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-13 10:56:51 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:44 +0000
commit054fda25eb205019352bc1637f08c6a00449624b (patch)
tree37b0939bf9ec7de02681bd2c18a28df78dfb2cfc /gnu/packages/golang.scm
parent431ebc223b46058bee0642ccbffe660cd622095e (diff)
downloadguix-054fda25eb205019352bc1637f08c6a00449624b.tar.gz
guix-054fda25eb205019352bc1637f08c6a00449624b.zip
gnu: go-github-com-google-go-querystring: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-google-go-querystring): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: Id2447d337708794bbf1f32791245b0687df5f19d
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9793e6702c..5577a285ba 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5395,33 +5395,6 @@ attributes. It also contains some convenience functions for colors, SSH to
and from termios translations, readCh, reading passwords, etc.")
(license license:bsd-3))))
-(define-public go-github-com-google-go-querystring
- (package
- (name "go-github-com-google-go-querystring")
- (version "1.1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/go-querystring")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "15k460c23nsmqd1nx3mvrnazws8bpb1gafrmffx7vf91m200mnwa"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/google/go-querystring/query"
- #:unpack-path "github.com/google/go-querystring"))
- (native-inputs
- (list go-github-com-google-go-cmp))
- (home-page "https://github.com/google/go-querystring/")
- (synopsis "Library for encoding structs into URL query parameters")
- (description
- "@code{go-querystring} is Go library for encoding structs into URL query
-parameters.")
- (license license:bsd-3)))
-
(define (go-gotest-tools-source version sha256-base32-hash)
(origin
(method git-fetch)