aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-24 20:07:28 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-28 15:15:43 +0100
commite48e8fe8d58b6f694ae36bfbdacf989c78985831 (patch)
tree837f117d28ccf8ab76cb89dc9a481f0770f05759 /gnu/packages/golang-xyz.scm
parent6fed47ad941808c855705f8fa7da37c52d686482 (diff)
downloadguix-e48e8fe8d58b6f694ae36bfbdacf989c78985831.tar.gz
guix-e48e8fe8d58b6f694ae36bfbdacf989c78985831.zip
gnu: go-github-com-klauspost-cpuid: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-klauspost-cpuid): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I85bc873816f653bf5e4ce2882259708d5f37ca28
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 2906e7ffff..e814731b63 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2152,6 +2152,33 @@ word-splitting rules.")
(home-page "https://github.com/kballard/go-shellquote")
(license license:expat))))
+(define-public go-github-com-klauspost-cpuid
+ (package
+ (name "go-github-com-klauspost-cpuid")
+ (version "1.2.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/klauspost/cpuid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1s510210wdj5dkamii1qrk7v87k4qpdcrrjzflp5ha9iscw6b06l"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/klauspost/cpuid"))
+ (home-page "https://github.com/klauspost/cpuid")
+ (synopsis "CPU feature identification for Go")
+ (description
+ "@code{cpuid} provides information about the CPU running the current
+program. CPU features are detected on startup, and kept for fast access
+through the life of the application. Currently x86 / x64 (AMD64) is
+supported, and no external C (cgo) code is used, which should make the library
+very eas to use.")
+ (license license:expat)))
+
(define-public go-github-com-lestrrat-go-envload
(package
(name "go-github-com-lestrrat-go-envload")