aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-20 16:37:01 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:00:59 +0100
commitd7f4f2c0538cdacf088f0108558c70656f96b4c2 (patch)
tree3c41708a40a7fbb2caf9479a03c33f928eebcf46 /gnu/packages/golang-xyz.scm
parentd43795cd208161495391104054e36abb94ea0a89 (diff)
downloadguix-d7f4f2c0538cdacf088f0108558c70656f96b4c2.tar.gz
guix-d7f4f2c0538cdacf088f0108558c70656f96b4c2.zip
gnu: go-github-com-stretchr-testify: Update to 1.9.0.
* gnu/packages/golang-check.scm (go-github-com-stretchr-testify): Update to 1.9.0. (go-github-com-stretchr-testify-next): Delete variable. (go-go-uber-org-goleak): [native-inputs]: Remove go-github-com-stretchr-testify-next; add go-github-com-stretchr-testify. * gnu/packages/golang-web.scm (go-github-com-quic-go-webtransport-go): [native-inputs]: Remove go-github-com-stretchr-testify-next; add go-github-com-stretchr-testify. * gnu/packages/golang-xyz.scm (go-github-com-masterminds-semver-v3, go-go-uber-org-dig, go-go-uber-org-fx, go-go-uber-org-zap): [native-inputs]: Remove go-github-com-stretchr-testify-next; add go-github-com-stretchr-testify. Change-Id: Ife39309254b5d89fcb61d84183771a4aab7e13db
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ebce00f117..cf29278501 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3111,7 +3111,7 @@ implementing features like:
(list
#:import-path "github.com/Masterminds/semver/v3"))
(native-inputs
- (list go-github-com-stretchr-testify-next))
+ (list go-github-com-stretchr-testify))
(home-page "https://github.com/Masterminds/semver/")
(synopsis "@code{semver} helps to work with semantic versions")
(description
@@ -5158,7 +5158,7 @@ CPU quota.")
(list
#:import-path "go.uber.org/dig"))
(native-inputs
- (list go-github-com-stretchr-testify-next))
+ (list go-github-com-stretchr-testify))
(home-page "https://pkg.go.dev/go.uber.org/dig")
(synopsis "Reflection based dependency injection toolkit for Golang")
(description
@@ -5184,7 +5184,7 @@ object dependencies graph during the process startup.")
(list
#:import-path "go.uber.org/fx"))
(native-inputs
- (list go-github-com-stretchr-testify-next))
+ (list go-github-com-stretchr-testify))
(propagated-inputs
(list go-go-uber-org-dig
go-go-uber-org-goleak
@@ -5252,7 +5252,7 @@ applications out of reusable, composable modules.")
(string-append "src/" import-path
"/stacktrace_ext_test.go")))))))
(native-inputs
- (list go-github-com-stretchr-testify-next
+ (list go-github-com-stretchr-testify
go-go-uber-org-goleak
go-golang-org-x-lint
go-honnef-co-go-tools))