aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 00:07:38 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 01:05:16 +0100
commitbddbb6631702c6e5516ee6f1f7f31f1c61c2bc03 (patch)
tree2fa08b3fbd500a75c3d30b5f929c381c4d529805 /gnu/packages/golang-xyz.scm
parent21b1f165c8534b771cd01dd3554e16dd8bca2396 (diff)
downloadguix-bddbb6631702c6e5516ee6f1f7f31f1c61c2bc03.tar.gz
guix-bddbb6631702c6e5516ee6f1f7f31f1c61c2bc03.zip
gnu: Add go-github-com-soniakeys-quant.
* gnu/packages/golang-xyz.scm (go-github-com-soniakeys-quant): New variable. Change-Id: I857c2c70f792bc5e69888eb64878299e0db94189
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 98da7f953f..4c8f4e87f9 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4749,6 +4749,29 @@ Use waterutil with it to work with TUN/TAP packets/frames.")
"@{gitconfig} is a package to get configuration values from gitconfig.")
(license license:expat)))
+(define-public go-github-com-soniakeys-quant
+ (package
+ (name "go-github-com-soniakeys-quant")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/soniakeys/quant")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0y50h4d9l4v1dxhf99ys6fha5c7viflwdnlfxn7glf2jr49x5z78"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/soniakeys/quant"))
+ (home-page "https://github.com/soniakeys/quant")
+ (synopsis "Interface for image color quantizers")
+ (description
+ "Quant provides an interface for image color quantizers.")
+ (license license:expat)))
+
(define-public go-github-com-spf13-cobra
(package
(name "go-github-com-spf13-cobra")