aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-03-08 21:23:25 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-16 22:59:47 +0000
commitaf714ebceedb14e3ed15fbb8cc471178d631bc6f (patch)
treef0f3876b4716fc00cad6402110aaa8d894de0b85 /gnu/packages/golang-xyz.scm
parentd2824346bc047562a67272e394f1fb1ab1f6b2be (diff)
downloadguix-af714ebceedb14e3ed15fbb8cc471178d631bc6f.tar.gz
guix-af714ebceedb14e3ed15fbb8cc471178d631bc6f.zip
gnu: Add go-github-com-jbenet-goprocess.
* gnu/packages/golang-xyz.scm (go-github-com-jbenet-goprocess): New variable. Change-Id: I5683a9e0df7bb1a17b2e813ab6c611f0b6c2ea9c Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ef700b9373..528c07d9f1 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1035,6 +1035,34 @@ increment versions.")
@end itemize")
(license license:bsd-3)))
+(define-public go-github-com-jbenet-goprocess
+ (package
+ (name "go-github-com-jbenet-goprocess")
+ (version "0.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jbenet/goprocess")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1z4a5skx9kh2c727pc6zz0vhf9v8acd320s7z0f1kwy3y1nbdhjk"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/jbenet/goprocess"))
+ (native-inputs
+ (list go-github-com-jbenet-go-cienv))
+ (home-page "https://github.com/jbenet/goprocess")
+ (synopsis "Manage process life cycles in Go")
+ (description
+ "@code{goprocess} introduces a way to manage process lifecycles in
+Go. It is much like @code{go.net/context} (it actually uses a Context), but it is
+more like a Context-WaitGroup hybrid. @code{goprocess} is about being able to start
+and stop units of work, which may receive @code{Close} signals from many clients.")
+ (license license:expat)))
+
(define-public go-github-com-jinzhu-copier
(package
(name "go-github-com-jinzhu-copier")