aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-21 13:28:45 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:01:01 +0100
commit9b8d1003c1fa73a5e33cc0d6eb2babc82af29970 (patch)
treec93d3782309a735eed290c6792b8f455b655a8d1 /gnu/packages/golang-xyz.scm
parent2a8637107c084f121f45e76c16680d123646eab7 (diff)
downloadguix-9b8d1003c1fa73a5e33cc0d6eb2babc82af29970.tar.gz
guix-9b8d1003c1fa73a5e33cc0d6eb2babc82af29970.zip
gnu: go-github-com-prometheus-client-model: Move to prometheus.
* gnu/packages/golang-xyz.scm (go-github-com-prometheus-client-model): Move from here ... * gnu/packages/prometheus.scm: ... to here. * gnu/packages/golang.scm: Add (gnu packages prometheus) module. * gnu/packages/networking.scm: Likewise. Change-Id: Ibbfc4100dfe33f9524eee99a461e7760f06a8eb3
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 4749fd5698..f007542b8a 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4232,34 +4232,6 @@ Pion}.")
"@code{refmt} is a serialization and object-mapping library.")
(license license:expat)))
-(define-public go-github-com-prometheus-client-model
- (package
- (name "go-github-com-prometheus-client-model")
- (version "0.6.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/prometheus/client_model")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0g1q2szzwp4rwkvayi2mnq2nwj6hj4ja7j43vwyi1iaz6d9z505c"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/prometheus/client_model"
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- ;; Source-only package
- (delete 'build))))
- (propagated-inputs
- (list go-github-com-golang-protobuf))
- (synopsis "Data model artifacts for Prometheus")
- (description "This package provides data model artifacts for Prometheus.")
- (home-page "https://github.com/prometheus/client_model")
- (license license:asl2.0)))
-
(define-public go-github-com-pterm-pterm
(package
(name "go-github-com-pterm-pterm")