aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-25 15:16:40 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:55 +0000
commit8ee3669af48d78c919b42b124eb05d7d2bf2a2d0 (patch)
tree318f554ac8244cd9e2def068f4c75783b0a45bec /gnu/packages/golang-xyz.scm
parent37ef7683de5f3f93c1dbbb15f78e02d4c6831089 (diff)
downloadguix-8ee3669af48d78c919b42b124eb05d7d2bf2a2d0.tar.gz
guix-8ee3669af48d78c919b42b124eb05d7d2bf2a2d0.zip
gnu: go-github-com-dustin-go-humanize: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-dustin-go-humanize): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/uucp.scm: Add golang-xyz module. Change-Id: Ic0913615d559ec255bf98abfab99383edf3c9a84
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 832e56b042..00361fec30 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020, 2021 raingloom <raingloom@riseup.net>
+;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2021 Collin J. Doering <collin@rekahsoft.ca>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Guix Together <jgart@dismail.de>
@@ -2399,6 +2400,30 @@ Implements string conversion functionality for unit prefixes.
scanner API made public.")
(license license:bsd-3)))
+(define-public go-github-com-dustin-go-humanize
+ (package
+ (name "go-github-com-dustin-go-humanize")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dustin/go-humanize")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1iyhd90pnmxh64nhsh6k02c1b1glpmhh4whga9jgb9g0i5hz3sya"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/dustin/go-humanize"))
+ (home-page "https://github.com/dustin/go-humanize")
+ (synopsis "Humane unit formatter")
+ (description
+ "@code{go-humanize} provides formatters for units to human friendly
+sizes. It converts boring ugly numbers to human-friendly strings and back.")
+ (license license:expat)))
+
(define-public go-github-com-edsrzf-mmap-go
(package
(name "go-github-com-edsrzf-mmap-go")