aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:38:26 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:38:26 +0100
commit88cdba5ccd021a0016c820fb615e29ca91f06c56 (patch)
treef6744b3e0f83e6943a497687a87b7f2ee4727650 /gnu/packages/golang-xyz.scm
parentc1e875eea340e7b14c41c6377df4dde74dee1145 (diff)
downloadguix-88cdba5ccd021a0016c820fb615e29ca91f06c56.tar.gz
guix-88cdba5ccd021a0016c820fb615e29ca91f06c56.zip
gnu: go-github-com-calmh-xdr: Move to golang-xyz.
* gnu/packages/syncthing.scm (go-github-com-calmh-xdr): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I201f5147de0a353057206ca314a685eb70622e00
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index f95e74a4ea..487a8fb1e1 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -774,6 +774,33 @@ indicator to any terminal application.")
similar to Go's standard library @code{json} and @code{xml} package.")
(license license:expat)))
+;; XXX: This repository has been archived by the owner on Feb 21, 2018. It is
+;; now read-only.
+(define-public go-github-com-calmh-xdr
+ (package
+ (name "go-github-com-calmh-xdr")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/calmh/xdr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "072wqdncz3nd4a3zkhvzzx1y3in1lm29wfvl0d8wrnqs5pyqh0mh"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/calmh/xdr"))
+ (home-page "https://github.com/calmh/xdr")
+ (synopsis "XDR marshalling and unmarshalling")
+ (description
+ "XDR is an External Data Representation (XDR)
+marshalling and unmarshalling library in Go. It uses code generation and not
+reflection.")
+ (license license:expat)))
+
(define-public go-github-com-cheggaaa-pb
(package
(name "go-github-com-cheggaaa-pb")