aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-13 11:51:46 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:45 +0000
commit838d28253065b268c026e7eb84dd2e3cede666ab (patch)
treedbece407664970e51a0b1cc561885d730cc75c82 /gnu/packages/golang-xyz.scm
parent43e019b561396b2667899a0d83a4b624c2f81369 (diff)
downloadguix-838d28253065b268c026e7eb84dd2e3cede666ab.tar.gz
guix-838d28253065b268c026e7eb84dd2e3cede666ab.zip
gnu: go-github-com-jonboulle-clockwork: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-jonboulle-clockwork): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Idf7a5958a856507f37d54771d6f4881b367ed39e
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 793d28523a..0c481f9715 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3935,6 +3935,30 @@ just matching lines. This package proviedes a CLI tool and @code{colors}
library.")
(license license:bsd-2)))
+(define-public go-github-com-jonboulle-clockwork
+ (package
+ (name "go-github-com-jonboulle-clockwork")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jonboulle/clockwork")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j1k9chzy5pb76r4r1k0vr5fbkvna564v6dzjflhapwsr7jpjgwf"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/jonboulle/clockwork"))
+ (home-page "https://github.com/jonboulle/clockwork")
+ (synopsis "Fake clock library for Go")
+ (description
+ "Replace uses of the @code{time} package with the @code{clockwork.Clock}
+interface instead.")
+ (license license:asl2.0)))
+
(define-public go-github-com-josharian-intern
(package
(name "go-github-com-josharian-intern")