aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:55:48 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:55:48 +0100
commit6d88e9e21f85cdd29fcdf6654b70bacd295be75b (patch)
treec1f187937a4bf2bd955992d3794488c3362179a0 /gnu/packages/golang-xyz.scm
parent856c3e08f73b60076670b9bf8a8bf5f0f21012ab (diff)
downloadguix-6d88e9e21f85cdd29fcdf6654b70bacd295be75b.tar.gz
guix-6d88e9e21f85cdd29fcdf6654b70bacd295be75b.zip
gnu: go-github-com-vitrun-qart: Move to golang-xyz.
* gnu/packages/syncthing.scm (go-github-com-vitrun-qart): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I219dfa1129e73e042170b3da176801a0058980f2
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5fe66bc67b..38fa1ea868 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3856,6 +3856,34 @@ supported by the time package
@end itemize")
(license license:expat)))
+(define-public go-github-com-vitrun-qart
+ (let ((commit "bf64b92db6b05651d6c25a3dabf2d543b360c0aa")
+ (revision "0"))
+ (package
+ (name "go-github-com-vitrun-qart")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vitrun/qart")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xk7qki703xmay9ghi3kq2bjf1iw9dz8wik55739d6i7sn77vvkc"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/vitrun/qart"))
+ (home-page "https://github.com/vitrun/qart")
+ (synopsis "Create QR codes with an embedded image")
+ (description
+ "This package provides a library for embedding human-meaningful
+graphics in QR codes. However, instead of scribbling on redundant pieces and
+relying on error correction to preserve the meaning, @code{qart} engineers the
+encoded values to create the picture in a code with no inherent errors.")
+ (license license:bsd-3))))
+
(define-public go-github-com-vividcortex-ewma
(package
(name "go-github-com-vividcortex-ewma")