aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-09 20:17:31 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-09 21:05:20 +0100
commit67147ccbe3fd2e34fa423d1a7f62ede0359021e2 (patch)
tree2aa94aab2c837cb0d8ac154ec2815c48f8c66e50 /gnu/packages/golang-xyz.scm
parent353d45389d02f6ce161b9b1ca4463f8d6c0b28f6 (diff)
downloadguix-67147ccbe3fd2e34fa423d1a7f62ede0359021e2.tar.gz
guix-67147ccbe3fd2e34fa423d1a7f62ede0359021e2.zip
gnu: Add go-github-com-opencontainers-runtime-spec.
* gnu/packages/golang-xyz.scm (go-github-com-opencontainers-runtime-spec): New variable. Change-Id: Ifb46706a137071677496d98e7801e6b0d3bd0bef
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0e4a796445..3dcbd88c10 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5394,6 +5394,35 @@ syslog, file and memory. Multiple backends can be utilized with different log
levels per backend and logger.")
(license license:bsd-3)))
+;; XXX: Find a way to source from specification-runtime-spec.
+(define-public go-github-com-opencontainers-runtime-spec
+ (package
+ (name "go-github-com-opencontainers-runtime-spec")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/opencontainers/runtime-spec")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "102smpg308dq984f6zkjzwq5jz8jbfswiwfwxcrp1hh197jydxf9"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/opencontainers/runtime-spec"
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'build)
+ (delete 'check))))
+ (home-page "https://github.com/opencontainers/runtime-spec")
+ (synopsis "OCI specs implementation in Golang")
+ (description
+ "This package provides a collection Golang implementation defined in
+specification-runtime-spec.")
+ (license license:asl2.0)))
+
(define-public go-github-com-openprinting-goipp
(package
(name "go-github-com-openprinting-goipp")