aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-18 19:00:24 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-03 22:23:23 +0100
commit512cd9aa7560cba398e2fb5229b23b9df9dfff5d (patch)
tree95834966812b9b7d4ee629e575bdfb5bd0005974 /gnu/packages/golang-xyz.scm
parentc0ae1fa13162b27179c70928904984011beb0d36 (diff)
downloadguix-512cd9aa7560cba398e2fb5229b23b9df9dfff5d.tar.gz
guix-512cd9aa7560cba398e2fb5229b23b9df9dfff5d.zip
gnu: Add go-github-com-jdkato-twine.
* gnu/packages/golang-xyz.scm (go-github-com-jdkato-twine): New variable. Change-Id: I13e55c204ab2072672a9556d7c0cac02f395116c
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 6f6167972f..2d669ec829 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2258,6 +2258,56 @@ more like a Context-WaitGroup hybrid. @code{goprocess} is about being able to s
and stop units of work, which may receive @code{Close} signals from many clients.")
(license license:expat)))
+(define-public go-github-com-jdkato-twine
+ (package
+ (name "go-github-com-jdkato-twine")
+ (version "0.10.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jdkato/twine")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hbpxcrcsbi975lklrhzyzk0fzn79pxicvfyf2sckmd2n6jb4ayy"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; FIXME: Adjust tests sute or check with upstram:
+ ;; === Failed
+ ;; === FAIL: nlp/segment TestGoldenRules (0.00s)
+ ;; segment_test.go:143: 25. Double quotations inside sentence
+ ;; segment_test.go:144: Actual: [She turned to him, "This is great." she said.]
+ ;; segment_test.go:145: Actual: 2, Expected: 1
+ ;; segment_test.go:146: ===
+ #:tests? #f
+ #:go go-1.21
+ #:import-path "github.com/jdkato/twine"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-module-import-path
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (substitute* (find-files "." "\\.go$")
+ (("gopkg.in/neurosnap/sentences.v1")
+ "github.com/neurosnap/sentences")))))
+ (replace 'build
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "build" "-v" "-x" "-ldflags=-s -w" "-trimpath" "./...")))))))
+ (native-inputs
+ (list gotestsum))
+ (propagated-inputs
+ (list go-github-com-montanaflynn-stats
+ go-github-com-neurosnap-sentences
+ go-github-com-errata-ai-regexp2))
+ (home-page "https://github.com/jdkato/twine")
+ (synopsis "NLP-related string utilities")
+ (description
+ "NLP-related string utility functions for Golang.")
+ (license license:expat)))
+
(define-public go-github-com-jinzhu-copier
(package
(name "go-github-com-jinzhu-copier")