aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-26 11:16:43 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:56 +0000
commit40c01f8dd3b8ab3f093838b1915a50ce74fd56c2 (patch)
tree89174e80560166fa77f2ec81538f3fdbe0b9b48c /gnu/packages/golang-xyz.scm
parentf680f932391ed282550e1bcb0fb47c637d4a2a97 (diff)
downloadguix-40c01f8dd3b8ab3f093838b1915a50ce74fd56c2.tar.gz
guix-40c01f8dd3b8ab3f093838b1915a50ce74fd56c2.zip
gnu: go-github-com-tekwizely-go-parsing: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-tekwizely-go-parsing): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/task-runners.scm: Swap imported module from golang to golang-xyz. Change-Id: I7a1fab8a1ab457011260ce7dac7a47ecf8f83dd3
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e346396088..0aeabccefa 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2021 Ramana Radhakrishnan <ramana.radhakrishnan@arm.com>
;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 raingloom <raingloom@riseup.net>
;;; Copyright © 2021, 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2022 (unmatched-parenthesis <paren@disroot.org>
@@ -7024,6 +7025,39 @@ calendar dates. It offers a complete implementation of the
@url{https://www.ietf.org/rfc/rfc2445.txt,RFC 2445} specification.")
(license license:expat)))
+;; XXX: Maybe split it into dedicated packages per module to easy importer.
+(define-public go-github-com-tekwizely-go-parsing
+ (package
+ (name "go-github-com-tekwizely-go-parsing")
+ (version "0.0.0-20221001173913-aa6d6749ea2d")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tekwizely/go-parsing")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hz4jwvav1ccvigmlxgg50pal3nxklbl0psf7wdzwr1vzmzmj3n3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/tekwizely/go-parsing"))
+ (home-page "https://github.com/tekwizely/go-parsing")
+ (synopsis "Text parsing, with lexers, parsers, and related tools")
+ (description
+ "This package provides Go modules focused on text parsing, with lexers,
+parsers, and related tools.
+
+Included modules are:
+@itemize
+@item github.com/tekwizely/go-parsing
+@item github.com/tekwizely/go-parsing/lexer
+@item github.com/tekwizely/go-parsing/lexer/token
+@item github.com/tekwizely/go-parsing/parser
+@end itemize")
+ (license license:expat)))
+
(define-public go-github-com-thejerf-suture
(package
(name "go-github-com-thejerf-suture")