aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-14 22:29:18 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:46 +0000
commit38cccec3cb8259851e33234207e84563222d0243 (patch)
tree8150318451cb24d9ec70f75bcfba80b7c8bdeedc /gnu/packages/golang-xyz.scm
parent72e51acb8e9a89d2dc3ac87c978c69671570b0b8 (diff)
downloadguix-38cccec3cb8259851e33234207e84563222d0243.tar.gz
guix-38cccec3cb8259851e33234207e84563222d0243.zip
gnu: Add go-github-com-cyphar-filepath-securejoin.
* gnu/packages/golang-xyz.scm (go-github-com-cyphar-filepath-securejoin): New variable. Change-Id: Id4468f224d1051bdc4b47c0d80cbfe02fb9d5cd3
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d38a2613d3..5857762a10 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1836,6 +1836,39 @@ submodules:
metrics to Graphite.")
(license license:bsd-2)))
+(define-public go-github-com-cyphar-filepath-securejoin
+ (package
+ (name "go-github-com-cyphar-filepath-securejoin")
+ (version "0.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cyphar/filepath-securejoin")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10clm1hfzndwhi7lwz5ph72apxwbxr3vg4nln5xsrrx26j6qv6v2"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:test-flags #~(list "-shuffle=on" "-v")
+ #:import-path "github.com/cyphar/filepath-securejoin"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-golang-org-x-sys))
+ (home-page "https://github.com/cyphar/filepath-securejoin")
+ (synopsis "Alternative Golang @code{filepath.SecureJoin} implementation")
+ (description
+ "Package securejoin is an implementation of the
+hopefully-soon-to-be-included @code{SecureJoin} helper that is meant to be
+part of the \"path/filepath\" package. The purpose of this project is to
+provide a @code{PoC} implementation to make the @code{SecureJoin} proposal
+(@url{https://github.com/golang/go/issues/20126,https://github.com/golang/go/issues/20126})
+more tangible.")
+ (license license:bsd-3)))
+
(define-public go-github-com-d4l3k-messagediff
(package
(name "go-github-com-d4l3k-messagediff")