aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-27 18:49:32 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-27 18:49:32 +0100
commit190c0abec86ae2d007330ed226033413997c1004 (patch)
treecb96a63292241ad0b4b35da59dcb4df210ebb81e /gnu/packages/golang-xyz.scm
parent33c4ad85c4ad38ad576004b66b4d8a2bd04ef0dc (diff)
downloadguix-190c0abec86ae2d007330ed226033413997c1004.tar.gz
guix-190c0abec86ae2d007330ed226033413997c1004.zip
gnu: go-github-com-avast-retry-go: Disable failing test.
Disable one failing test as seen in <https://ci.guix.gnu.org/build/5268812/details>. * gnu/packages/golang-xyz.scm (go-github-com-avast-retry-go) [arguments]: <#:phases>: Add 'disable-failing-tests phase. Change-Id: I95af4f01f254d5229c84754626502d768c730c39
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 144941c31b..d8fa82d4c1 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -844,6 +844,11 @@ stored in a Go struct.")
#:import-path "github.com/avast/retry-go"
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (substitute* (find-files "." "\\_test.go$")
+ (("TestMaxDelay") "OffTestMaxDelay")))))
(add-after 'unpack 'remove-examples
(lambda* (#:key import-path #:allow-other-keys)
(delete-file-recursively