aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 22:10:27 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 22:36:58 +0100
commit07420241df3fa3001a606724eb1e281a83989e6e (patch)
treed82291bfcb0e2efaacfa7f6c5b53912d95e5cb45 /gnu/packages/golang-xyz.scm
parent14c1a4bec96b346e65193bb7e6f7f3749bbf9b9e (diff)
downloadguix-07420241df3fa3001a606724eb1e281a83989e6e.tar.gz
guix-07420241df3fa3001a606724eb1e281a83989e6e.zip
gnu: go-github-com-arran4-golang-ical: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-arran4-golang-ical): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Iec66cbbab2bce986201ddacaaa643d7410f57ca6
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 71bfeb0be5..f7e534d908 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -861,6 +861,33 @@ optimized for sparse nodes of
@url{http://en.wikipedia.org/wiki/Radix_tree,radix tree}.")
(license license:expat)))
+(define-public go-github-com-arran4-golang-ical
+ (package
+ (name "go-github-com-arran4-golang-ical")
+ (version "0.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arran4/golang-ical")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gcn5afds1dnq3wrl4ndi4wqqwmrnvh9pdqhyv77d3cqakn82vj3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/arran4/golang-ical"))
+ (native-inputs
+ (list go-github-com-google-go-cmp
+ go-github-com-stretchr-testify))
+ (home-page "https://github.com/arran4/golang-ical")
+ (synopsis "Handle iCalenders in Go")
+ (description
+ "The @code{ical} package provides an ICS/iCalender parser and serialiser
+for Go.")
+ (license license:asl2.0)))
+
(define-public go-github-com-audriusbutkevicius-recli
(package
(name "go-github-com-audriusbutkevicius-recli")