aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-19 22:24:25 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:00:58 +0100
commit058e0cc75a2cb7dc81386b994084f162e75cb552 (patch)
tree4a908a018e1d466e723576f0355fa0cb5829ba13 /gnu/packages/golang-xyz.scm
parentbdff9d26423a62f246882a46c5440c144c54910c (diff)
downloadguix-058e0cc75a2cb7dc81386b994084f162e75cb552.tar.gz
guix-058e0cc75a2cb7dc81386b994084f162e75cb552.zip
gnu: go-github-com-google-go-cmp-cmp: Rename variable.
* gnu/packages/golang.scm (go-github-com-google-go-cmp-cmp): Rename variable to go-github-com-google-go-cmp, which reflects go.mod import path and improves importer performance. (go-github-com-zclconf-go-cty, go-golang-org-x-vuln, go-google-golang-org-protobuf, go-gotest-tools-assert, go-gotest-tools-internal-source, go-gotest-tools-internal-format, gofumpt, gopls, gotestsum): Swap go-github-com-google-go-cmp-cmp to go-github-com-google-go-cmp in inputs, propagated-inputs or native-inputs. * gnu/packages/golang-check.scm (go-github-com-frankban-quicktest, go-github-com-google-go-cmdtest): Likewise. * gnu/packages/golang-web.scm (go-github-com-aws-aws-sdk-go-v2, go-github-com-aws-aws-sdk-go-v2-config, go-github-com-aws-smithy-go, go-github-com-go-jose-go-jose-v3, go-github-com-makeworld-the-better-one-go-gemini, go-golang-org-x-oauth2, go-gopkg-in-square-go-jose-v2): Likewise. * gnu/packages/golang-xyz.scm (go-github-com-goccy-go-yaml): Likewise. * gnu/packages/check.scm (actionlint): Likewise. * gnu/packages/databases.scm (sqls): Likewise. * gnu/packages/ipfs.scm (go-github-com-ipld-go-ipld-prime, go-github-com-whyrusleeping-cbor-gen): Likewise. * gnu/packages/web.scm (go-github-com-itchyny-gojq): Likewise. Change-Id: Ie6eeba936f7da404d70fbbaad34f5b43aec4e05b
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 6560f43578..ebce00f117 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2154,7 +2154,7 @@ the library more lightweight.")
(invoke "go" "test" "-v" "./..."))))))))
(native-inputs
(list go-github-com-go-playground-validator-v10
- go-github-com-google-go-cmp-cmp))
+ go-github-com-google-go-cmp))
(propagated-inputs
(list go-github-com-fatih-color
go-golang-org-x-xerrors))
/commit/tests/profiles.scm?id=113c17a0c969e600023698ae3a34994a796d0046'>profiles: Gracefully deal with packages containing an etc/ symlink....Ludovic Courtès 2015-05-08profiles: Ensure the profile's etc/ directory is writable....Ludovic Courtès