aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorThomas Ieong <th.ieong@free.fr>2024-02-01 20:36:04 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-01 20:49:00 +0000
commitdf65af45b5f2cc76ce813ca91fab9054fd807bba (patch)
tree1ec99257ace7fa02f24af4823a8a08d21bce46bb /gnu/packages/golang-web.scm
parent6f78803b01d416ab421ba860751b764b9e4f33db (diff)
downloadguix-df65af45b5f2cc76ce813ca91fab9054fd807bba.tar.gz
guix-df65af45b5f2cc76ce813ca91fab9054fd807bba.zip
gnu: Add go-minify.
* gnu/packages/golang-web.scm (go-minify): New variable. Co-authored-by: Sharlatan Hellseher <sharlatanus@gmail.com> Co-authored-by: Hilton Chain <hako@ultrarare.space> Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Ic9b1c12ea477aa5ad194482f2ade58da029cadc4
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index dd84962110..41626c9856 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -44,10 +45,12 @@
#:use-module (guix build-system go)
#:use-module (guix gexp)
#:use-module (guix git-download)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-check)
#:use-module (gnu packages golang-crypto)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages tls)
#:use-module (gnu packages web))
@@ -1515,6 +1518,25 @@ Signing and Encryption set of standards. This includes support for JSON Web
Encryption, JSON Web Signature, and JSON Web Token standards.")
(license license:asl2.0)))
+(define-public go-minify
+ (package
+ (inherit go-github-com-tdewolff-minify-v2)
+ (name "go-minify")
+ (arguments
+ (substitute-keyword-arguments
+ (package-arguments go-github-com-tdewolff-minify-v2)
+ ((#:install-source? _ #t) #f)
+ ((#:import-path _ "github.com/tdewolff/minify/v2")
+ "github.com/tdewolff/minify/cmd/minify")))
+ (inputs
+ (list go-github-com-djherbis-atime
+ go-github-com-dustin-go-humanize
+ go-github-com-fsnotify-fsnotify
+ go-github-com-matryer-try
+ go-github-com-spf13-pflag))
+ (description "This package provides a CLI binary executible built from
+go-github-com-tdewolff-minify-v2 source.")))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar