aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-08-11 00:09:57 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-21 13:43:26 +0100
commitd43d3bbf3bef881e238368d10c81919028d6cedb (patch)
tree199095fd7a6f1c97e681187fd98167b3a4248e60 /gnu/packages/golang-web.scm
parent0408934fc4d45e027ec723797e9ff6fccd15956d (diff)
downloadguix-d43d3bbf3bef881e238368d10c81919028d6cedb.tar.gz
guix-d43d3bbf3bef881e238368d10c81919028d6cedb.zip
gnu: Add go-github-com-libp2p-go-netroute.
* gnu/packages/golang-web.scm (go-github-com-libp2p-go-netroute): New variable. Change-Id: I46ed313a1c96cf5b9d126fa48791351a13d66f32 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 2257b9b399..cbd4be9af0 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2124,6 +2124,43 @@ router.")
@acronym{Simple Service Discovery Protocol, SSDP}} library for Golang.")
(license license:expat)))
+(define-public go-github-com-libp2p-go-netroute
+ (package
+ (name "go-github-com-libp2p-go-netroute")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libp2p/go-netroute")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06p68j63fd5nf2gf1fz2pnksmdmv735swpbpvnhb15vrgg3r528g"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/libp2p/go-netroute"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (substitute* (find-files "." "\\_test.go$")
+ ;; Test requiring network access: no route found for 8.8.8.8
+ (("TestRoute") "OffTestRoute"))))))))
+ (propagated-inputs
+ (list go-github-com-google-gopacket
+ go-golang-org-x-net
+ go-golang-org-x-sys))
+ (home-page "https://github.com/libp2p/go-netroute")
+ (synopsis "Routing table abstraction library for Golang")
+ (description
+ "@code{go-netroute} provides an implementation of the
+@url{https://godoc.org/github.com/google/gopacket/routing#Router,
+gopacket/routing.Router} interface for Golang.")
+ (license license:bsd-3)))
+
(define-public go-github-com-makeworld-the-better-one-go-gemini
(package
(name "go-github-com-makeworld-the-better-one-go-gemini")